locked
Error deploying POC TP3 - Invocation of interface 'Configure' of role 'Cloud\Fabric\ADFS' failed - Step: Status of step '60.120.120 - (Katal) Configure ADFS' is 'Error' RRS feed

  • Question

  • Hi all,

    can I get an assist?  attempting to install Azure TP3 - my server is a little older but still has life! (IBM x3650M3). 

    When I restart the asdk installer script is says the installation is done...based on the log erroring out I don't think it is!  Help!

    After running about 4 1/2 hours I got this error:

    >>>>>>>

    2017-07-13 17:52:05 Verbose  2> 3> [ASAppGateway:Deployment] Initializing remote powershell session on AzS-Xrp01.azurestack.local with common functions.
    2017-07-13 17:52:05 Verbose  2> 3> [ASAppGateway:Deployment] Loading infra vm helpers (C:\CloudDeployment\Common\InfraVmHelpers.ps1) to session on AzS-Xrp01.azurestack.local
    2017-07-13 17:52:05 Verbose  2> 8> [IBC:Deployment] Initializing remote powershell session on AzS-ERCS01.azurestack.local with common functions.
    2017-07-13 17:52:05 Verbose  2> 8> [IBC:Deployment] Loading infra vm helpers (C:\CloudDeployment\Common\InfraVmHelpers.ps1) to session on AzS-ERCS01.azurestack.local
    2017-07-13 17:52:06 Verbose  2> 2> [InfraServiceController:Deployment] Update code package only for role InfraServiceController
    2017-07-13 17:52:07 Verbose  2> 2> [InfraServiceController:Deployment] Prepare default app parameter for DEV cluster...
    2017-07-13 17:52:07 Verbose  2> 2> [InfraServiceController:Deployment] [MinReplicaSetSize]=1 | [TargetReplicaSetSize]=1 | [PartitionCount]=1 | [InstanceCount]=1
    2017-07-13 17:52:07 Verbose  2> 2> [InfraServiceController:Deployment] Need update [EndpointCertThumbprint]
    2017-07-13 17:52:07 Verbose  2> 2> [InfraServiceController:Deployment] No specific application manifest parameter for [InfraServiceController]. Skip!
    2017-07-13 17:52:07 Verbose  2> 2> [InfraServiceController:Deployment] Start to deploy application [fabric:/AzureStackIscApplication] on service fabric cluster...
    2017-07-13 17:52:07 Verbose  2> 2> [InfraServiceController:Deployment] Upgrade? [False]
    2017-07-13 17:52:09 Verbose  2> 2> [InfraServiceController:Deployment] Initializing remote powershell session on AzS-Xrp01.azurestack.local with common functions.
    2017-07-13 17:52:09 Verbose  2> 2> [InfraServiceController:Deployment] Loading infra vm helpers (C:\CloudDeployment\Common\InfraVmHelpers.ps1) to session on AzS-Xrp01.azurestack.local
    2017-07-13 17:52:17 Verbose  2> 7> [ECE:Deployment] Start to deploy application [fabric:/EnterpriseCloudEngineApplication] on service fabric cluster...
    2017-07-13 17:52:17 Verbose  2> 7> [ECE:Deployment] Upgrade? [False]
    2017-07-13 17:52:17 Verbose  2> 7> [ECE:Deployment] Initializing remote powershell session on AzS-ERCS01.azurestack.local with common functions.
    2017-07-13 17:52:17 Verbose  2> 7> [ECE:Deployment] Loading infra vm helpers (C:\CloudDeployment\Common\InfraVmHelpers.ps1) to session on AzS-ERCS01.azurestack.local
    2017-07-13 17:52:25 Warning  1> Task: Invocation of interface 'Configure' of role 'Cloud\Fabric\ADFS' failed:

    Type 'Configure' of Role 'ADFS' raised an exception:

    ADMIN0121: An attempt to update service settings failed because the data set that was used for updating was stale. Refresh the data in your session or console view, and then try the update again.
    at Configure-ADFS, D:\AzureStack.Setup.5.14.525\content\Setup\Scripts\Adfs\Configure-Adfs.ps1: line 272
    at <ScriptBlock>, D:\AzureStack.Setup.5.14.525\content\Setup\Scripts\Adfs\Configure-Adfs.ps1: line 307
    at <ScriptBlock>, <No file>: line 15
    2017-07-13 17:52:25 Error    1> Task: Invocation of interface 'Configure' of role 'Cloud\Fabric\ADFS' failed:

    Type 'Configure' of Role 'ADFS' raised an exception:

    ADMIN0121: An attempt to update service settings failed because the data set that was used for updating was stale. Refresh the data in your session or console view, and then try the update again.
    at Configure-ADFS, D:\AzureStack.Setup.5.14.525\content\Setup\Scripts\Adfs\Configure-Adfs.ps1: line 272
    at <ScriptBlock>, D:\AzureStack.Setup.5.14.525\content\Setup\Scripts\Adfs\Configure-Adfs.ps1: line 307
    at <ScriptBlock>, <No file>: line 15
    2017-07-13 17:52:25 Verbose  1> Step: Status of step '60.120.120 - (Katal) Configure ADFS' is 'Error'.

    < SNIP >

    2017-07-13 17:52:25 Verbose  1> Step: Status of step '60.120.120 - (Katal) Configure ADFS' is 'Error'.
    2017-07-13 17:52:25 Verbose  1> Checking if any of the in progress steps are complete. The following steps are currently in progress: '60.120.120'.
    2017-07-13 17:52:25 Verbose  1> Action: Action plan 'Deployment-Phase4-IdentitySystemAndWASBootstrap' failed. Finish running all steps that are currently in progress before exiting.
    2017-07-13 17:52:25 Verbose  1> Draining all steps that are still in progress. The following steps are still in progress or just completed: '60.120.120'.
    2017-07-13 17:52:25 Verbose  1> Action: Action plan 'Deployment-Phase4-IdentitySystemAndWASBootstrap' failed.

    >>>>



    Friday, July 14, 2017 4:37 PM

Answers

All replies

  • Hello,

    This is an known issue with the asdk-installer. 

    Please try running the following to restart your deployment.

    cd C:\CloudDeployment\setup

    .\InstallAzureStackPOC.ps1 -rerun

       

     Thanks,


    Gary Gallanes

    Friday, July 14, 2017 4:58 PM
  • okay - will give it a go

    update: you were correct - restarted and it ran to completion.

    Friday, July 14, 2017 5:17 PM