none
problems with Azure recovery services vault RRS feed

  • Question

  • I have setup an azure recover services vault and i have downloaded the azure MicrosoftAzureSiteRecoveryConfigurationServer.ova and i have created a VM based on the OVA and i went through the configuration steps. I am trying to replicate two local VM based guest machines. I have single host running ESXI 6.5 and I dont have V center. So I added the credential for the ESXI, added the credential to access the guest VMs and i think i completed the installation of the configuration server successfully and I can see it on my azure portal. Then I tried to use the azure portal to add both VMs to the site replication. Unfortunately only one of the two VMs was succesfully registerd and added to the site recovery. The other erred with a message the the agent couldnt be installed

    The one that succeeded has been at 0% sync for more than 24 hours. In between I have tried several times to add the second VM but no success. I tried to do the agent installation manually on the second VM but the final configuration fails when I type the IP address and the passphrase. i did a genpassphrase.ex -n on the config server and i tried that passphrase. I also checked the connectivity between the two IPs and it was good. somehow this is not getting accepted. and the first server still at 0% after 24 hours with no error messages on the azure portal. I have a feeling this is an agent problem on both servers. on the first server somehow the agent doesnt work and on the second server it refuses to be final configured after installation. Can someone help?

    Friday, January 24, 2020 10:58 PM

All replies

  • Possibility,  in portal, check the VM Vault you created, Site Recovery Infrastructure -> Under VMWare -> Configuration Servers -> Look for your Config Server there,  click it and check that your Process, Vcenter, Target server are all there and connected.

    I had issue with 0% sync,  I remove all the agents on the VM, reboot, reinstall and it started working..  very weird..  this was something that was working for 6 month and all of sudden it stopped

    Monday, January 27, 2020 1:57 PM
  • I checked the process server and it showed no issues. But I am getting nowhere with microsoft on this. It seems like this either works or it doesnt. So I went another way, kind of what you are suggesting ++

    I erased the configuration server VM and I build a new one from the ova. I went to my vault and redid everything from the beginning. I cleaned up the VMs to be protected, rebooted and installed the agent myself this time. And it is working. I spent a day tinkering with this but thankfully I dont need anymore tech support. If the same things happens again I will do the same. Get rid of some microsoft buggy thing and reinstall it. Thanks God this is not my only backup. It is plan B.

    on another note, you seem to have some experience and you might have some suggestions. I cannot remove the old configuration server from the vault. It looks ugly. Trust me I tried to remove it before I deleted this VM and didn't work either. Do you know of any way cleaning up my vault from old junk like this configuration server and old "protected" VMs that don't really work? I tried several times to delete and it times out.

    Let me know if you have any suggestions. There is no functionality issue having some old non working config servers etc but it looks ugly and I like to do clean work.

    thanks a lot !

    Monday, January 27, 2020 8:16 PM
  • Sorry for the painful experience. 

    Refer to the steps in the link - https://docs.microsoft.com/en-us/azure/site-recovery/vmware-azure-manage-configuration-server#delete-or-unregister-a-configuration-server to delete/remove configuration server.

    ------------------------------------------------------------------------------------------------------------------------
    If this answer was helpful, click “Mark as Answer” and Up-Vote. Feel free to reach out to us if you've any further questions in this matter. 

    Friday, February 7, 2020 10:10 AM
    Moderator