locked
Datazen Support RRS feed

  • Question

  • I using Datazen Publisher to add data from local Excel, cell with Excel formula was imported correctly into Data View.

    But when I use Datazen Server import excel file with "Excel Documents in a Network Share", all the cells with formula changed to 0 value.

    How to I fix this issue? please help!!!!

    Thanks in advance.

    Wednesday, July 26, 2017 10:00 AM

All replies

  • Hi Terry8516,

    Based on my research, Datazen Server-published dashboards can connect to Excel documents in network shares. Please check the following conditions:

    Keep datatypes consistent within each column

    Format cells as proper types in Excel

    When using formulas, ensure that the entire column is calculated using the same formula

    Use Excel 2007 or later

    Save Excel files with the extension XLSX

    You can refer to this thread for details.

    And if you download the file in local then import it to Datazen, will this issue occur? In addition, please check the column data type, it might be converted to other data type.

    If you have any question, please feel free to ask.
    Best regards,
    Zoe Zhi

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, July 28, 2017 1:24 AM
  • Connection is working fine. The problem is happen to the excel cell that contain formula.

    I use same excel file to import direct from Datazen Publisher, all cell with formula is working. But this file didn't work when import into Datazen Server.

    eg.

    excel cell "=1+1" Datazen Publisher will show "2"

    excel cell "=1+1" Datazen Server will show "0"

    FYI, my server did not install MS Office.

    Monday, July 31, 2017 3:55 AM
  • I've install MS office into the Server but excel cell with formula still return "0" value when import into Datazen Server.

    Btw my Datazen version is, Server: 3.0.2962 (Enterprise Mode).

    Anyway to fix this problem?

    Monday, July 31, 2017 7:07 AM
  • Anyone has solution?

    I've tried many ways, but can't resolved this issue.

    Thursday, August 3, 2017 7:25 AM