locked
How I turn off control bouncing on the edge of screen? RRS feed

  • Question

  • I have control as FlipView, ScrollViewer , ... ,

    when i fast panning to clash the edge of screen, control is boucing back.

    How I can turn off it?

    Thank you.

    Wednesday, August 7, 2013 9:49 AM

All replies

  • I think you would need to override the ItemsControl.ItemContainerTransitions property.  Question is, why?  This is part of the Store app experience, most people expect this.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Thursday, August 8, 2013 2:20 PM
    Moderator
  • I think you would need to override the ItemsControl.ItemContainerTransitions property.  Question is, why?  This is part of the Store app experience, most people expect this.

    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    I think no about ItemContainerTransitions when items entered.

    When I scroll by touch to the last item. I continue scrolling that the last item have bounce-back effect.

    I would disable bounce-back effect.

    P.S. Such As Iphone have  Control.Bounce = NO

    Thank you.

    Friday, August 9, 2013 2:51 AM