locked
EW4 "Not Responding" on FTP Publish RRS feed

  • Question

  • Using FTP to transfer a single file from EW4 to the FTP server takes approximately 30 seconds. This is a single HTML file that's only a few kilobytes in size. We'll right click on a file, select "Publish Selected Files ....", EW4 will appear to hang (the title bar says "Not Responding") and about 20 - 30 seconds later EW4 will come out of it's trance, the transfer will have completed, and we can see the updated file when browsing the site. The big questions are: why is the publishing process so slow? How can we speed it up?

    This is definitely not a FTP server or network issue. We can access the site with our FTP client (FTP Voyager) and it only takes a few seconds to connect and a fraction of a second to upload a file. There's a lot of files in the web root (12,000+) but again, the FTP client has no trouble enumerating and displaying in a timely manner. An it certainly does not enter the "Not Responding" state.

    So, is it possible to speed up EW4 FTP uploads?

     

    Sunday, August 8, 2010 6:58 PM

Answers

  • Tried the Passive connection toggle - no luck with that. I think it's a server-side issue. While it works fine with FTP Voyager other clients like Filezilla are not working at all.

    We ended up publishing using Frontpage extensions instead of FTP. There's still a slight delay, but the program remains responsive.

    Monday, August 9, 2010 9:48 PM

All replies

  • It does that. What I do is to just publish the file I have edited by doing a CNTL + SHIFT + U. That just moves one file and EW does not go through the whole checking process to decide what it should upload as it does when you publish the site. Or, you can highlight a few files in the Folder List pane and or a directory and right click and select "Publish Selected Files". This will also bypass the heavy publishing burden.
    Sunday, August 8, 2010 8:21 PM
  • EW will run through all the pages when you go to publish to see what the publishing status is. Large sites will cause it to take awhile.

    If you are going to publish just one file or a couple select them in folder list and from the right click menu select "Publish selected files" as the fastest way to publish just a file or two w/o indexing the whole site.


    MS MVP Expression Tutorials & Help http://by-expression.com
    Sunday, August 8, 2010 8:23 PM
  • That's the odd thing - the slow "Not Responding" behavior occurs when we right-click a *single* small file for upload. The same results occur for CTRL+SHIFT+U as well.
    Sunday, August 8, 2010 8:27 PM
  • I get the same small delay for large sites and small when I do the CTRL+SHIFT+U. There may be some issue with your ftp configuration or some other installation error. Sorry, it's now outside of my experience.
    Sunday, August 8, 2010 8:38 PM
  • Hi Lee,

    Just a guess here, but worthy of a try. Toggle passive connection in the publishing section - if its on, shut it off, and visa versa.

     

    Rick

     


    rickidoo
    Sunday, August 8, 2010 11:13 PM
  • Tried the Passive connection toggle - no luck with that. I think it's a server-side issue. While it works fine with FTP Voyager other clients like Filezilla are not working at all.

    We ended up publishing using Frontpage extensions instead of FTP. There's still a slight delay, but the program remains responsive.

    Monday, August 9, 2010 9:48 PM