locked
Kinect v2 + ASRock Z77 Pro3 + Windows 8.1 RRS feed

  • Question

  • Hello!

    I just recieved my Kinect v2 and it's not working. I get this message in the Configuration Verifier, after I connected it to my onboard (ASRock Z77 Pro3 ) USB 3 port:

    "Supported USB 3.0 port detected with unknown bandwidth. Kinect may or may not be compatible with your hardware."

    I disconnected all my other usb devices but it didn't work. Does this mean the Z77 isn't compatible? Or is this just a driver problem? I think the ASRock got a Intel USB Chipset which should work?

    Thank you.

    Tarek

    Monday, November 3, 2014 11:54 PM

Answers

All replies

  • Solved it. I had to install the windows media feature pack!
    Tuesday, November 4, 2014 2:05 AM
  • Terek, Carmine

    I have the same Kinect v2 problem (usb 3.0 unknown bandwidth) with my Z77 pc (Asus P8Z77-V LX Motherboard, Intel i7-2600K CPU, 16GB, Syba Renesas usb 3.0 card) , Win. 8.1 64

    I tried to install  "Windows Media Feature Pack", but it's available only for N, NK versions of Win 8.1. It's not applicable to regular Win 8.1.  

    Do you mean I need to upgrade to Win 8.1 Pro and/or Win 8.1 Media Center Pack?

    Do you have your 3D Builder running at 30 fps with Kinect v2? 

    Thanks, Vlad

    Sunday, January 18, 2015 4:46 PM
  • I had the same hardware and the same problem. In my case, disconnecting all USB devices (except for the Kinect v2) then restarting the computer (important!) resolved the problem. I didn't need to install any media packs.
    Tuesday, January 20, 2015 12:00 AM
  • Is you advised, I tried to disconnect all usb devices (found ps/2 keyboard and ordered/purchased special connector for this mb - took some time). As one might expected, this didn't make any difference - my bandwidth still "unknown" to "Configuration Verifier".  I also tried other computers: hp envy 15 touchscreen (i7 quad core + nvidia, 2013), dell xps 15 (i7+nvidia, 2015), lenovo 15 (i7+nvidia) - all of them failed usb 3.0 bandwidth test. Surface i5 fail the test as well (don't see reasons why surface i7 will pass if latest lenovo laptop failed). Only last option I see is to purchase new Z97 chipset based motherboard and i7-4770k/4790k processor and try. If such configuration will  succeed, than it should be considered as the realistic minimal/recomended PC configuration to work with MS Kinect v2 for Win.

    Will try to add screenshots later.



    • Edited by Vlad Mishin Friday, January 30, 2015 12:15 AM
    Friday, January 30, 2015 12:13 AM
  • We routinely run Kinect v2 on Surface Pro 3 tablets and on desktop PC components that were manufactured in 2014 and those all work fine. On the other hand, we have not been able to get Kinect v2 to work on any equipment manufactured before 2014. Kinect v2 now runs fine on my ASRock Z777, but only after I bought 2014-era USB 3 adapters which I connected directly to the motherboard.
    Friday, January 30, 2015 12:55 AM
  • Below are the screenshots for 2015 hardware as well as my older PC - none had passed usb 3.0 verification. 

    {drive.google.com/folderview?id=0B3kOc6fcjPC6fnVLa2RGTV9kaDZYVWRySlJmdEVXRTZiWWNXcUpac0pIT3dNWjU0RjBadUU&usp=sharing}

    It would be great to see some of your usb 3.0 successful verification screen.


    • Edited by Vlad Mishin Friday, January 30, 2015 8:49 PM
    Friday, January 30, 2015 8:40 PM
  • Using the "Kinect v2 Configuration Verifier", in my experience, the entry "USB Controller" always says: "(!) Supported USB 3.0 port detected with unknown bandwidth. Kinect may or may not be compatible with your hardware." In the past few minutes, I ran the verifier program on a Surface Pro 3 (the lowest-end model) and my screenshot looks the same as yours.

    I have never seen a green checkmark next to "USB Controller". On every computer where I use a Kinect v2, "USB Controller" always shows the same exclamation point and the same warning message, the same as in your screenshot. But the Kinect v2 still seems to work and to provide data. So these days I just ignore the "USB Controller" warning because it doesn't seem to convey any useful or actionable information.

    Friday, January 30, 2015 9:06 PM
  • Very good, now we are on the same page. Yes, I'm also getting data from Kinect, but still want to clarify with Kinect team whether this is a bug or what are the specific conditions to satisfy to make "USB Controller" test green.
    Friday, January 30, 2015 9:55 PM
  • If you can ensure the system and bandwidth are running optimally(30fps for Kinect and CPU/Memory/etc. are not over utilized) you can safely ignore the warning. Hardware bandwidth is not a bug software can correct for. If your system can not sustain the bandwidth requirements for USB3/PCI Express Gen 2.0 then you can't expect to sustain the 30fps from Kinect.

    You can review the troubleshooting guide for additional things to try if you are not getting 30fps: https://social.msdn.microsoft.com/Forums/en-US/20dbadae-dcee-406a-b66f-a182d76cea3b/troubleshooting-and-common-issues-guide?forum=kinectv2sdk


    Carmine Sirignano - MSFT

    Monday, February 2, 2015 7:00 PM
  • Carmine,

    I tried several (7) systems including newest from Dell and Lenovo and none of them passes usb 3.0 test. That why it might be the bug in software which leads to wrong bandwidth measurement. All computers I tried has USB3/PCI Express Gen 2.0 or 3.0 - which means that Gen 2.0, i7, etc .. this is not sufficient. Just show me the screen shot of the system, you or your colleagues are using or provide configuration (cpu, mb chip) where you've seen successful usb 3.0 test. That will save me and other Kinect adopters lots of time and money.

    Let me know if more clarification is desirable, Vlad



    • Edited by Vlad Mishin Saturday, February 7, 2015 7:19 PM
    Saturday, February 7, 2015 7:13 PM
  • Depending on make/model and revision of the chipset there may be a architectural problem as in wired into a PCI Express v1 bus that is not capable of full speed USB3.

    for list of known devices to work have a look at this thread: https://social.msdn.microsoft.com/Forums/en-US/bb379e8b-4258-40d6-92e4-56dd95d7b0bb/confirmed-list-of-usb-30-pcie-cardslaptopsconfigurations-which-work-for-kinect-v2-during?forum=kinectv2sdk

    Driver and chipset issues are handled at the operating system level which has nothing to do with Kinect. The tool provided does a basic check on USB3 capabilities but as stated many times a "orange" status is not a failure state. If the driver and/or device communication is not running a full "super" speed, that will delay data getting to the runtime which is a user mode level component. If we are not running at full bandwidth(30fps) then that will just cause known issues to occur.

    For known issues and workarounds with bandwidth you can review the troubleshooting thread: https://social.msdn.microsoft.com/Forums/en-US/20dbadae-dcee-406a-b66f-a182d76cea3b/troubleshooting-and-common-issues-guide?forum=kinectv2sdk


    Carmine Sirignano - MSFT

    Monday, February 9, 2015 7:31 PM
  • Carmine,

    I reviewed those links again.

    On the 1st link people discussing just general functionality. I tried Surface, and couple more configs - none of them passed the usb 3.0 test to the green level.

    The second link has reference to the blog "How to determine whether a USB 3.0 device is operating at SuperSpeed?" 
    http://blogs.msdn.com/b/usbcoreblog/archive/2012/06/27/how-to-determine-whether-a-usb-3-0-device-is-operating-at-superspeed.aspx

    I followed their recommendations (installed USBView with WDK) and find out that my usb 3.0 is operating at Super speed (5 Gb), but Kinect still is not happy.

    Please check  my screen shot here:  https://drive.google.com/file/d/0B3kOc6fcjPC6U19laFhPdGpXU28/view?usp=sharing

    That means either Kinect firmware has the bug, which prevents utilization of usb 3.0 bandwidth, or "Configuration Verifier" has some problems or Windows 8.1 usb 3.0 driver or Intel.

    I'm excluding Intel and Win 8.1 usb3.0 driver for now.

    It would be great if you would ask developers to review "Conf. Verifier" code and possibly firmware to understand why USB 3.0 SuperSpeed mode is not handled correctly. I suspect it might be the problem associated with the code handling datastream from XBox One USB 3.0 and Windows 8.1 USB 3.0.  

    Thanks, Vlad



    • Edited by Vlad Mishin Thursday, February 12, 2015 10:59 PM
    Thursday, February 12, 2015 5:48 PM
  • Hope there would be less problems with ORBEC sensor:

    http://shop-orbbec3d-com.3dcartstores.com/Orbbec-Astra-Pro_p_35.html


    • Edited by Vlad Mishin Thursday, February 18, 2016 11:41 PM
    Thursday, February 18, 2016 11:40 PM
  • Problem SOLVED!

    It became apparent that "Kinect v2 Configuration Verifier" is not testing USB 3.0 speed at all. If to disconnect Kinect from PC it will keep showing warning: "Supported USB 3.0 port detected with unknown bandwidth. ...". It means, that this test is irrelevant - they probably just checking for some name, but don't measure real data transfer speed. Strange, that it was never clear communicated by MS Kinect Support despite causing lot of questions.

    Thanks, Vlad

    Wednesday, June 22, 2016 10:30 PM