none
Report Viewer Control Not Showing On Winform RRS feed

  • Question

  • Hello all.

    I have a problem as to where when I I drap the ReportViewer control onto any blank form in my project, it does not display at all in the project. It only displays below the form where tableadapters would show up. I can create a new project and it is just fine. I can also add that control to older projects and it shows. What could be wrong.

     
    Wednesday, February 11, 2009 6:14 PM

Answers

  • I'm not sure what is causing the problem for one specific project, but that symptom tends to be a result of Visual Studio not loading the report viewer design assembly.  You might be able to fix the problem by specifically adding a reference to Microsoft.ReportViewer.Design.dll to your project.
    Sunday, February 15, 2009 7:28 PM
    Moderator

All replies

  • I'm not sure what is causing the problem for one specific project, but that symptom tends to be a result of Visual Studio not loading the report viewer design assembly.  You might be able to fix the problem by specifically adding a reference to Microsoft.ReportViewer.Design.dll to your project.
    Sunday, February 15, 2009 7:28 PM
    Moderator
  • In my case the existing reference had some warnings, I've removed and added it again and works perfect, thanks.

    Saturday, July 11, 2015 7:20 PM
  • I know this post is 5 years old but I am having the same exact issue using VS2013. When I drag the report viewer onto the form it shows up down where the table adapters are.  I tried adding the direct reference to Microsoft.ReportViewer.Design.dll.    I deleted the form and I cannot get the reportview to show up properly.  I also tried to bring the report viewer onto many of my other forms and the same thing happens.  As above, my other applications don't have this issue.  Any help would be appreciated.  Stuck....

    Thamas g. Nohs

    Friday, August 14, 2015 9:10 PM
  • I solved this problem to adding in VS2013 project  the lastest DLL version of Microsoft.ReportViewer.Common and Microsoft.ReportViewer.WinForm.

    I created a new winform VS2013 project and drag in to winform the reportviewer control. In the reference i find the correct path for the lastest VS2013 DLL version (by click the property of the single dll in the reference). 

    When i find this new version of dll (version 11) i replace the old dll version in my project and when i drop a reportviewer the control is showed.

    Friday, October 2, 2015 10:39 AM
  • You are right, I changed the reference to the actual DLL, not only in the toolbox!

    THANKS

    Friday, August 25, 2017 5:28 PM