locked
Samsung S4 Permissions Problem RRS feed

  • Question

  • User117 posted

    After the 4 Sept Samsung MH8 (JDQ37) firmware upgrade, some of my Samsung S4 users are now getting the following error message: 'An application has been forced to stop for an unauthorized attempt to access system in your device' when they try to sync our app's database with their PC database. This uses the following adb command: "C:\Program Files (x86)\MyApp\adb.exe" push "C:\Program Files (x86)\MyApp\MyApp.db" data/data/MyApp.MyApp/files/MyApp.db". This returns 'Permission denied' now. The file has attributes world readable and world writable and syncing has always worked fine until this upgrade. The upgrade introduced Samsung Knox which is obviously preventing the file transfer to the app's data/data/MyApp.MyApp/files/ folder. Has anybody come across this issue before - and perhaps found a solution?

    Sunday, October 20, 2013 11:33 AM

All replies

  • User117 posted

    As I've had no response to this, I guess no one is (yet) testing their app(s) with the Samsung S4 (unrooted and with the MH8 firmware installed - introducing Knox security) using adb to send/receive files to it? Have googled extensively on this subject to no avail. Can anyone help with this please?

    Monday, October 28, 2013 11:52 AM
  • User8232 posted

    I have the same issues with my Galaxy Note 10.1 2014 with android 4.3. Can someone help us please?

    Monday, November 4, 2013 10:18 AM
  • User117 posted

    Still haven't got any further with this I'm afraid. My customer (who has now upgraded to Android 4.3) now gets the attached message. Haven't heard yet what happens when he presses the 'Update' button.

    Monday, November 4, 2013 10:32 AM
  • User209 posted

    Well I guess Samsung is a bit paranoid about APK files coming from an unknown source. I guess this does not happen with apps coming from the Play Store. What options do you have under "Developer options"?

    Monday, November 4, 2013 2:34 PM
  • User117 posted

    Yes, it also happens with apps coming from the Play store. Unfortunately, I don't have a Samsung S4 to test with myself, so I'm having to rely on feedback from customers having the problem. This problem may be resolvable by 'Force Stopping' Knox and the Security Policy Updater, but I'm waiting for customer feedback on this.

    Tuesday, November 5, 2013 8:55 AM
  • User21936 posted

    Hi all,

    I found an article by Samsung that describes how to uninstall Samsung Knox Personal: http://www.samsung.com/us/support/howtoguide/N0000005/13093/159642 I found another option to disable Samsung Knox here: http://www.droidviews.com/disable-knox-security-service-on-samsung-galaxy-devices/ It might also be as simple as switching to Samsung Knox Personal mode. This can be done using shortcuts from the app tray and the notification tray.

    Jon

    Tuesday, November 5, 2013 7:44 PM
  • User14244 posted

    Just disable FastDev. Your project should then deploy. I ran into the same issue a few days ago.

    Hopefully Samsung wises up. I don't need all that extra crap they are slamming on the device.
    If they are going to push an update, don't install crap apps that I didn't have before and don't want.

    Friday, November 8, 2013 10:11 PM
  • User28251 posted

    I just got my S4 last week and am sad to say that i also stumbled across the Knox app. It scared the heck out of me when i tried to uninstall the app through settings and was unable to. But.........I FIGURED IT OUT!!!!!!!!!!!

    1. Pull down top menu

    2. Turn on Knox (you'll need to use the password and actually sign in)

    3. Once in Knox, hit the menu button in the bottom left corner of you phone and select Knox settings

    4. The setting menu will pop up and at the bottom of the menu click "About Knox"

    5. There are three options on the screen,(I can't remember what they are because two of them were unimportant and I refuse to download Knox again so that I can read them. But...) the bottom option is uninstall Knox.

    6. Uninstall Knox

    I have learned a very valuable lesson in all this. I will be reading blogs and reviews on any and all apps from now on before installing. I hope people are able to find and use this information. If anyone reads this who has a YouTube channel, do this and post it, i bet you'll get a bunch of hits. much love kids. Commence to Jigglin yal'

    Wednesday, November 13, 2013 7:26 AM
  • User1669 posted

    So I don't have an S4, but am considering one as a test device. Other than uninstalling Knox, has anyone figured out why Knox would be preventing any particular app from running? Has anyone found a list of "Do's and Don't". Perhaps, as developers, we should be thinking about ways of making this work, rather than telling users to uninstall Knox. Granted many power consumers probably will, but I'm thinking in the case of enterprise apps in where my clients may want to utilize Knox. For example, If I'm building an app for a client and a security requirement is that is runs in the Knox sandbox. Anyone found any developer guidance?

    Wednesday, November 13, 2013 1:10 PM
  • User30041 posted

    I'm having the same problem. Knox is not even installed. Is there an improvement? Thank you..

    Tuesday, November 26, 2013 8:07 AM
  • User17522 posted

    Having this issue as well and Knox isn't installed. Just updated our S3 to 4.3. Any ideas?

    Wednesday, December 11, 2013 12:48 AM
  • User17522 posted

    Bumping this. We are still having this issue. Is there a fix other than turning off fast dev?

    Wednesday, December 18, 2013 9:10 PM
  • User468 posted

    I am also experiencing this issue. Just updated my Note2 to JB 4.3. Can anyone from Xamarin maybe comment on the issue?

    Thursday, December 19, 2013 3:20 AM
  • User3521 posted

    I am also experiencing the same issue on my Galaxy Note 10.1 2014 Edition (without Knox).

    Tuesday, January 14, 2014 5:26 AM
  • User10501 posted

    Breps is right, just : "Just disable FastDev. Your project should then deploy."

    Where?

    Go to your project options -> android Build -> disable use shared mono runtime, fast assembly deployment.

    Wednesday, January 29, 2014 6:48 PM
  • User26483 posted

    Yep....just did it myself, disabling FastDev solves the issue

    Wednesday, January 29, 2014 11:04 PM