locked
Report Builder over SSL/HTTPS RRS feed

  • Question

  • We're using SSRS 2008. How do you use Report Builder over SSL/HTTPS? We have reports being delivered over the internet using SSL/HTTPS and everything works fine except Report Builder. When using standalone version 2.0 I can point to shared data sources succesfully but nothing after that - when I create the datasets I get the following message (at the point of validating the SQL):

    A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)

    When using version 1.0 (via click-once), it says 'Verifying Application Requirements' for a few seconds and then gives the error below: Cannot Retrieve Application. Authentication Error .. and here are a few of the lines from the Details.

    https://domain/ReportBuilder/ReportBuilder.application resulted in exception. Following failure messages were detected:
      + Downloading https://domain/ReportBuilder/ReportBuilder.application did not succeed.
      + The remote server returned an error: (401) Unauthorized.

    Has anyone succeeded in using Report Builder (whether via click-once or standalone) to work in this way?

    Thanks!

    Thursday, March 25, 2010 1:10 PM

Answers

  • Hi rrd31,

    I have also deployed the same environment before, and I am sure Report Builder is working with SSL.

    In this case, the error seems to be caused by the client can't connect to the datasource. Could you please check the datasource is available?

    By the way, please check if there is any error in the SQL Server Reporting Services logs. That will help us to solve the issue.

    Thanks,

    Jin Chen


    Jin Chen - MSFT
    Wednesday, March 31, 2010 12:08 PM