locked
Drag & Drop image tags to local directory RRS feed

  • Question

  • Original web built in FP 2000, now trying EW4. In FP, the "folder list" directory was the website address (http://www.mywebsite.com, for example) but in EW4 the folder list directory is C:\My Documents.  When I edit a webpage and drag an image onto the page, it gives it a tag of C:\my documents\image.jpg.  If I publish this to the server website, how will anyone be able to look at the image? Can I get EW4 to look at the website folder list in http://www.mywebsite.com?  What am I missing?
    bob
    Tuesday, February 1, 2011 5:09 PM

Answers

  • Sounds like you were working live over FPSE with FrontPage. In Expression Web you need to define a local site. I'd suggest that you spend a little time working through the Learning Resources section of the Before Posting sticky. Pay particular attention to the Basic Website tutorial and the frontpagetoexpression.com material.
    Expression Web Tutorials & Help http://by-expression.com
    Expression Web forums
    • Marked as answer by tractorbob Tuesday, February 1, 2011 5:59 PM
    Tuesday, February 1, 2011 5:40 PM
  • Did you actually create a website in C:\My Documents\My Websites ?
    You should see:  C:\My Documents\My Websites\websitename 
    You need to and then always import images into the images folder inside websitename and then insert them into the page.

     

     


    Expression Web MVP
    • Marked as answer by tractorbob Tuesday, February 1, 2011 10:19 PM
    Tuesday, February 1, 2011 5:48 PM
  • If you are working correctly, you will *not* see "C:\My Documents" names in your links.  You wil see relative addresses, e.g., "../images/file.jpg" or "images/picture.jpg" or "logo.gif".  These will work locally and on your published site.

    Create a local site in EW.  Publish your existing site down into it.  Open that local site in EW and edit it.

    • Marked as answer by tractorbob Tuesday, February 1, 2011 10:19 PM
    Tuesday, February 1, 2011 10:14 PM

All replies

  • Sounds like you were working live over FPSE with FrontPage. In Expression Web you need to define a local site. I'd suggest that you spend a little time working through the Learning Resources section of the Before Posting sticky. Pay particular attention to the Basic Website tutorial and the frontpagetoexpression.com material.
    Expression Web Tutorials & Help http://by-expression.com
    Expression Web forums
    • Marked as answer by tractorbob Tuesday, February 1, 2011 5:59 PM
    Tuesday, February 1, 2011 5:40 PM
  • Did you actually create a website in C:\My Documents\My Websites ?
    You should see:  C:\My Documents\My Websites\websitename 
    You need to and then always import images into the images folder inside websitename and then insert them into the page.

     

     


    Expression Web MVP
    • Marked as answer by tractorbob Tuesday, February 1, 2011 10:19 PM
    Tuesday, February 1, 2011 5:48 PM
  • If you are working correctly, you will *not* see "C:\My Documents" names in your links.  You wil see relative addresses, e.g., "../images/file.jpg" or "images/picture.jpg" or "logo.gif".  These will work locally and on your published site.

    Create a local site in EW.  Publish your existing site down into it.  Open that local site in EW and edit it.

    • Marked as answer by tractorbob Tuesday, February 1, 2011 10:19 PM
    Tuesday, February 1, 2011 10:14 PM