none
Biztalk Db2 adapter issue RRS feed

  • Question

  • We had this error in production this morning. No idea why. The integration has been polling successfully for a few days and when the error occurred there were no traffic. 

    Solved it just by restarting the host instance but really want to know why so we can prevent it in the future.


    The adapter "DB2" raised an error message. Details "A network library error has occured (-2147418113): Catastrophic failure

     SQLSTATE: HY000, SQLCODE: -2147418113".

    /Mats

    Update: It happened twice now. Seems to be every 48 hours.

    Update: It seems we have not configured MSDTC correctly. Every poll towards the database starts a transaction that is not finished. After too many sessions we are blocked from the database.

    https://msdn.microsoft.com/en-us/library/bb726925%28v=bts.10%29.aspx

    Anybody knows correct settings for DTC in this case?

    • Edited by MatsIrem Tuesday, April 14, 2015 7:15 PM
    Tuesday, April 7, 2015 7:13 AM

Answers

  • Hi,

    Try the following:

    • In the DB2 connection string: Units of Work=DUW;
    • For the Local DTC Security configuration (via Component Services): Enable XA Transactions

    • Marked as answer by MatsIrem Monday, June 15, 2015 9:07 AM
    Friday, May 15, 2015 5:13 AM

All replies

  • The adapter "DB2" raised an error message. Details "A network library error has occured (-2147418113): Catastrophic failure

     SQLSTATE: HY000, SQLCODE: -2147418113".

    /Mats

    Can you provide more information about this problem?
    Wednesday, April 8, 2015 3:12 AM
  • Hi,

    We are polling a table in a DB2 database on an AS400 server. After the select we are doing a delete on the same rows using the very same adapter. Things went fine for about 48 hours before this happened. After a restart a the host instance it works fine again. We dont want to get into a situation where we have to restart things without any idea of why.

    Wednesday, April 8, 2015 6:36 AM
  • Hi,

    Try the following:

    • In the DB2 connection string: Units of Work=DUW;
    • For the Local DTC Security configuration (via Component Services): Enable XA Transactions

    • Marked as answer by MatsIrem Monday, June 15, 2015 9:07 AM
    Friday, May 15, 2015 5:13 AM