none
HCK has an unspecified error when testing USB device RRS feed

  • Question

  • I am testing an Serial-USB adapter. I passed all HCK test in client Win8 x86 but got error in Win8 x64. (RTM)

    The test environment are all the same and I use an USB host adapter with Renesas 201 chipset.

    The all 4 items I can't pass due to the same error code: 0x80004005.

    They are USB Descriptor Test, USB Device Control Request Test, USB Selective Suspend Test (xHCI) and USB MS OS Descriptor Test (XHCI). 

    How do I solve this problem?

    The content of USBHCTxHCI.txt is listed below

    -------------------------------------------------------------------
    4564 3328 2013:2:28 0:2:56:340 Machine: Build=9200.00    Platform=AMD64    OS=Windows 8 Enterprise Evaluation    ServicePack=""    Version=6.2    BuildLab="win8_rtm"    BuildDate=120725-1247    Language=English (US) (REDMOND)    Config=n/a     
    4564 3328 2013:2:28 0:2:56:387 Device port path found: 8  
    4564 3328 2013:2:28 0:2:56:402 Updating device PCI\VEN_1912&DEV_0014&SUBSYS_00000000&REV_03\4&14486AD3&0&00E0 to use driver from INF path E:\WLK\JobsWorkingDir\Tasks\WTTJobRun19599CDE-D4D7-403B-87C7-B91B8D52BFED\driver\xhcidrv.inf  
    4564 3328 2013:2:28 0:3:0:675 Driver update was successful  
    4564 3328 2013:2:28 0:3:0:675 Info: Test log initialized.  
    4564 3328 2013:2:28 0:3:0:675 Info: Windows version 6.2 (Build 9200)  
    4564 3328 2013:2:28 0:3:17:971 Root port 8, route string 000000  
    4564 3328 2013:2:28 0:3:17:971 Error: 0x80004005, Unspecified error   Couldn't get CDevice pointer to device under test   File=testsrc\driverstest\usb\cvmodified\wlk\compliancestackhelper\helper.cpp Line=885  
    4564 3328 2013:2:28 0:3:17:971 Updating device PCI\VEN_1912&DEV_0014&SUBSYS_00000000&REV_03\4&14486AD3&0&00E0 to use driver from INF path C:\Windows\inf\usbxhci.inf  
    4564 3328 2013:2:28 0:3:20:519 Driver update was successful  
    4564 3328 2013:2:28 0:3:20:519 Summary: Total=0, Passed=0, Failed=0, Blocked=0, Warned=0, Skipped=0  


    JosJos

    Wednesday, February 27, 2013 8:34 AM

All replies

  • Hi  JosJos,

    I also got the same problem with Renesus 201 chipset for those 4 items. After applied WHCK filter #1159, you can get the result passed.  This errata will be expired until Oct.1, 2013.

    I usually use PCs with on-board Intel USB3.0 controller to pass the items.

      

    Wednesday, February 27, 2013 11:56 PM
  • Dear YoYamada,

    Thank for your reply. It is helpful information. However I still get failed result on these tests.

    I will try to change the different USB hosts and platforms now.


    JosJos

    Monday, March 4, 2013 11:48 AM
  • Hi JosJos, I got once same situation with specific older client and server combination.Try to use another PC or confirm if you apply the latest WHCK. Thanks.
    Wednesday, March 6, 2013 12:19 AM