locked
Term Store missing complete list of terms RRS feed

  • Question

  • In my Term Store Management Tool, when I expand a Term Set, it is not listing all terms.   It used to list the complete list of terms, but just recently it doesn't .  The down arrow is missing where you would click to see the rest of the terms.  It only lists the first 10 terms. 

    Anyone know how to fix this to be able to see the complete list of terms?

    I know they are still there, as I can see all the terms when I upload a document (metadata choices).

    thanks!

    Monday, November 3, 2014 5:15 PM

Answers

  • IE 11 by any chance? 

    Generally when I have browser quirks like this when accessing Microsoft products using a Microsoft browser, I switch to a non-MS browser such as Chrome and it then works. 

    But, if you are using IE 11 and want to stick with it. Open up the Term Store, then...

    - F12

    - Ctrl-8

    - It probably says "8 (Default)" in the document mode.

    - Change it to 10. (Or if you you are fully updated in IE 11, there's a small drop down thingy on the right that also allows you to change it.) You can shrink it down. (Closing it puts it back to IE 8 mode.)

    Unfortunately, it doesn't stick when re-opening the browser and Compatibility Mode doesn't help (or it didn't in my case). The only way I could make it "stick" was to use Chrome, but IE gurus may be able to help more as I'm not IE expert.



    Tuesday, November 4, 2014 11:28 AM
  • "The down arrow is missing". This is the OP's problem and I can also reproduce it. So, if you have 25 items, the first 10 show and there is no way to access the other 15. IE developer mode indicates it's a bug in treecontrol.js. 

    "you can change the IE browser mode using F12" That is exactly what I suggested in my post - it works. 

    • Marked as answer by lorrdellatorre Thursday, November 6, 2014 6:07 PM
    Tuesday, November 4, 2014 1:05 PM

All replies

  • And the strange part is, if I click on the Term Set and choose "Create Term", then click away on another part of the screen (so as to not really create a new term), then the down arrow appears for me to see the rest of the list of terms.

    But I shouldn't have to do this work-around to be able to see the complete list of terms under a Term Set.

    Monday, November 3, 2014 5:35 PM
  • IE 11 by any chance? 

    Generally when I have browser quirks like this when accessing Microsoft products using a Microsoft browser, I switch to a non-MS browser such as Chrome and it then works. 

    But, if you are using IE 11 and want to stick with it. Open up the Term Store, then...

    - F12

    - Ctrl-8

    - It probably says "8 (Default)" in the document mode.

    - Change it to 10. (Or if you you are fully updated in IE 11, there's a small drop down thingy on the right that also allows you to change it.) You can shrink it down. (Closing it puts it back to IE 8 mode.)

    Unfortunately, it doesn't stick when re-opening the browser and Compatibility Mode doesn't help (or it didn't in my case). The only way I could make it "stick" was to use Chrome, but IE gurus may be able to help more as I'm not IE expert.



    Tuesday, November 4, 2014 11:28 AM
  • Hi,

    According to your post, my understanding is that you can’t see the down arrow to view the rest terms which are more than 10.

    In my environment, I also do this test and the result is that it works well.

    Per my knowledge, it’s by design that the terms only can show the top 10 terms under a term set, then you can click on the drop arrow to view rest terms which are more than 10.

    You can try to create a new Term Set or a Group, and separately do this test again to check if this issue only occurs on this term set.

    What is your current browser? I recommend that you can change some different browsers to check if this issue only occurs on your current browser.

    If you are using the IE browser, you can change the IE browser mode using F12, change to different mode, then check whether it works.

    You can try to clear the browser cache and run the IE in safe-mode again to test if it works.

    Also, I suggest that it’s better to use the IE 8 browser for SharePoint 2010.

    And, does this issue occurs after you install any update in your environment?

    I recommend that you can try to install the latest update in your environment to check if it works.

    Best Regards,

    Yumi Fu

    • Edited by Yumi Fu Tuesday, November 4, 2014 12:41 PM
    Tuesday, November 4, 2014 12:38 PM
  • "The down arrow is missing". This is the OP's problem and I can also reproduce it. So, if you have 25 items, the first 10 show and there is no way to access the other 15. IE developer mode indicates it's a bug in treecontrol.js. 

    "you can change the IE browser mode using F12" That is exactly what I suggested in my post - it works. 

    • Marked as answer by lorrdellatorre Thursday, November 6, 2014 6:07 PM
    Tuesday, November 4, 2014 1:05 PM
  • Thank you MarkT.

    Yes, I'm using IE 11.

    I'm annoyed with compatibility issues between IE and Sharepoint.  All IE versions should work with all SharePoint features; You would think!!

    I'll try your suggestion.

    Thursday, November 6, 2014 6:07 PM
  • LOL. Yes, you'd think so, but this isn't the only example. Here's an official MS one: http://support.microsoft.com/kb/2900662 demonstrating IE11's issues working with MS web sites. Oh dear...


    Friday, November 7, 2014 4:11 PM
  • Error solved in this hotfix:

    https://support.microsoft.com/kb/2899490

    You can also replace treecontrol.js by an old one.

    Best regards


    Mysonemo Consultant SharePoint

    Tuesday, December 2, 2014 9:21 AM