locked
SSRS 2008- Underlying connection was closed – could not establish trust relationship for SSL/TLS RRS feed

  • Question

  • Everything is on my local laptop. No issues with Web page URL etc (using fully qualified name). After connecting to SSRS thru SSMS, right-click on Jobs/Security/Shared Schedules, will get the error below.

    How to fix this? (already tried some solutions posted). Thanks for the help.

    Monday, April 16, 2012 12:26 PM

Answers

  • Hi Dennis,

    From your description, the issue may be caused by the Secure Sockets Layer (SSL) certificate is installed on the report server. If the SSL Identity is not a necessity, you can remove the SSL Identity from the Reporting Services Configuration Manager. Otherwise, to narrow down the root cause, I suggest you help to clarify:

    1. Can you access the Report Server and Report Manager through the SSL Identity URLs properly?
    2. Navigate to <Drive>:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportServer folder, open the RSReportserver.config file and check the value of the “SecureConnectionLevel” key.
    3. In the Reporting Services Configuration Manager, click the “Web Service URL” tab, click “Advanced…”, and then please elaborate how the SSL Identities are configured. If possible, I suggest that you post a screenshot of the window. 

    In addition, I also suggest that you remove the current SSL Identities from Reporting Services Configuration Manager, create a Self-Signed Certificate in Internet Information Services (IIS), and then check the issue using the new certificate. For the details, please see:
    Create a Self-Signed Server Certificate in IIS 7

    References:

    If you have any questions, please feel free to let me know.

    Regards,
    Mike Yin

    • Marked as answer by Elvis Long Sunday, April 22, 2012 10:10 AM
    Tuesday, April 17, 2012 8:50 AM
  • I too had this issue. It is resolved by placing the fully quailified URL for the service in the Server Name section of the login area when connecting to Reporting Services via SSMS. https://server.domain.com/reportserver .

    • Proposed as answer by Florida_guy Thursday, January 17, 2013 4:50 PM
    • Marked as answer by Mike Yin Friday, January 18, 2013 2:40 AM
    Thursday, January 17, 2013 3:14 PM

All replies

  • Hi Dennis,

    From your description, the issue may be caused by the Secure Sockets Layer (SSL) certificate is installed on the report server. If the SSL Identity is not a necessity, you can remove the SSL Identity from the Reporting Services Configuration Manager. Otherwise, to narrow down the root cause, I suggest you help to clarify:

    1. Can you access the Report Server and Report Manager through the SSL Identity URLs properly?
    2. Navigate to <Drive>:\Program Files\Microsoft SQL Server\MSRS10.MSSQLSERVER\Reporting Services\ReportServer folder, open the RSReportserver.config file and check the value of the “SecureConnectionLevel” key.
    3. In the Reporting Services Configuration Manager, click the “Web Service URL” tab, click “Advanced…”, and then please elaborate how the SSL Identities are configured. If possible, I suggest that you post a screenshot of the window. 

    In addition, I also suggest that you remove the current SSL Identities from Reporting Services Configuration Manager, create a Self-Signed Certificate in Internet Information Services (IIS), and then check the issue using the new certificate. For the details, please see:
    Create a Self-Signed Server Certificate in IIS 7

    References:

    If you have any questions, please feel free to let me know.

    Regards,
    Mike Yin

    • Marked as answer by Elvis Long Sunday, April 22, 2012 10:10 AM
    Tuesday, April 17, 2012 8:50 AM
  • Hi Dennis ,

    I have the same issue were you able to find a solution for this ..

    Thanks,

    Jack

    Wednesday, October 17, 2012 4:48 PM
  • I too am having the same problem with 2008 R2.  Everything works fine in the web browser using the identity URL, but management studio balks. 

    The only cert on the system is a computer cert, deployed via autoenrollment from our CA (Server 2012).  Obviously the hostname matches the cert, and the issuing authority is trusted.

    Of course, changing the secureconnectionlevel setting from 2 to 0 resolves the issue, but it shouldn't even *be* an issue. 

    Tuesday, November 13, 2012 9:31 PM
  • I too had this issue. It is resolved by placing the fully quailified URL for the service in the Server Name section of the login area when connecting to Reporting Services via SSMS. https://server.domain.com/reportserver .

    • Proposed as answer by Florida_guy Thursday, January 17, 2013 4:50 PM
    • Marked as answer by Mike Yin Friday, January 18, 2013 2:40 AM
    Thursday, January 17, 2013 3:14 PM