locked
Could not load file or assembly 'Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified. RRS feed

  • Question

  • Hi,

    Our development team is trying to run a report on our report server through web application but they are getting the below error. Report Viewer both version 10 and 11 are already installed on our reporting server. 

    [System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.
    File name: 'Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'

    The files are in place in assembly folder 'C:\Windows\assembly' and DLLs are also in place in folder 'C:\Program Files (x86)\Microsoft Visual Studio 10.0\ReportViewer. 

    Can anyone please help us with this issue. 

    Thanks

    Wednesday, April 8, 2015 5:05 AM

Answers

  • Hi Saurabh,

    This error means you're using the SQL Server Reporting Services ReportViewer control in your web application and the server can't find the proper DLL.

    Please check details information below to add the 'Microsoft.ReportViewer.WebForms.dll 10.0.0.0 to see if your problem will be resolved:

    1. Go to right click on project name to select the properties
    2. Check the References on the left and click "Add", then click Browse to the path "C:\Windows\assembly\GAC_msil" to select Microsoft.ReportViewer.WebForms.dll 10.0.0.0 , then click ok

    If above didn't help. please also the web.config file which path like:
    C:\Program Files\Microsoft SQL Server\MSRS12.MSSQLSERVER\Reporting Services\ReportManager
    C:\Program Files\Microsoft SQL Server\MSRS12.MSSQLSERVER\Reporting Services\ReportServer

    Please check to add below configuation:

    <system.web>
         <httpHandlers>
           <add path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=10.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" validate="false" />
         </httpHandlers>
     </system.web>

    Similar thread in below article for your reference:
    http://praveenbattula.blogspot.com/2010/03/fix-to-report-viewer-problems-in-iis-7.html
    User can not run a winForm with the ReportView Control
    Can not load Reportviewer
    If you still have any problem, please feel free to ask.

    Regards,
    Vicky Liu


    Vicky Liu
    TechNet Community Support


    • Proposed as answer by Vicky_Liu Wednesday, April 15, 2015 1:14 AM
    • Marked as answer by Vicky_Liu Thursday, April 16, 2015 1:03 AM
    Thursday, April 9, 2015 8:32 AM