locked
SQLserver won't start, can't view site on localhost RRS feed

  • Question

  • User1988740161 posted

    Hi.  I couldn't find a sqlserver forum, so I'm going to try this one.  I'm helping my kids build a 4h website based on the club starterkit.  It looks like it will work great.  But, we can't view the site in a browser because of the following error

    TITLE: .Net SqlClient Data Provider
    ------------------------------

    An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

    When I enable named pipes, the server won't respond in a timely manner and when I try to start sqlserver it says I need admin priveledges.  When I try to make myself admin I get another error.

    We are using SQLserver express 2005 with Vista Home Pro.  The program used to work with Vista Basic, but when I upgraded Vista won't let me start the program because I'm not the administrater (except I AM the Administrater).  Yesterday I uninstalled sqlserver and downloaded a new copy with SP2 and installed it.  The program worked perfectly and I was in business.  I turned off my computer for the night and this morning I'm getting the same error.  Please help.  I'm sure there must be some simple thing that I can do to give myself admin priveledges to start sqlserver, but I'm totally stumped.

    Wednesday, September 24, 2008 1:49 PM

Answers

  • User-1757793930 posted

    I would say you are right with that one.

    Try a few things. first try turning UAC off through the control panel and repeat the steps
         http://www.vista4beginners.com/How-to-disable-UAC
    Load a command prompt as administrator (right click on the command prompt icon and click run as adminitrator) and try this command to manually start MS Sql  sqlcmd -S.\sqlexpress
         http://blogs.msdn.com/sqlexpress/archive/2004/07/23/192044.aspx
    Try opening surface area configuration with admin privalages (like above) and try starting the sql server.

    If that fails install XP (ok thats a joke really i use Vista and would go back). [:)]

     

    Let me know how it goes

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, September 25, 2008 1:01 AM
  • User1988740161 posted

    Hi.  Thanks, I did follow your suggestion....sort of.  I turned off UAC in the control panel and tried going through the steps again.  No luck.  So I turned it back on.  I tried going through the steps  with "run as administrator" a couple of times.  No luck.  By this time I was just sort of randomly trying things, and then, suddenly it was running. Unfortunately, I don't know why.  I haven't shut down or restarted my computer since.  I'm pretty sure if I shut it down, the program will be stopped again.  So my problem is for the moment fixed.  Thanks

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, September 27, 2008 1:13 PM

All replies

  • User-1757793930 posted

    Here is a microsoft KB for this sort of problem. Also you have to make sure the sql server is running, which the kb should help you with.

    http://support.microsoft.com/kb/914277

    Wednesday, September 24, 2008 2:15 PM
  • User1988740161 posted

    Thanks for the reply.  I have followed the protocol you suggest with no success.  the error I get is

    TITLE: Surface Area Configuration
    ------------------------------

    The service did not respond to the start or control request in a timely fashion, you need administrator privileges to be able to start/stop this service. (SQLSAC)

    I have tried everything I can think of.  I am pretty sure the problem has to do with UAC in Vista.  Please help.

    Wednesday, September 24, 2008 7:45 PM
  • User-1757793930 posted

    I would say you are right with that one.

    Try a few things. first try turning UAC off through the control panel and repeat the steps
         http://www.vista4beginners.com/How-to-disable-UAC
    Load a command prompt as administrator (right click on the command prompt icon and click run as adminitrator) and try this command to manually start MS Sql  sqlcmd -S.\sqlexpress
         http://blogs.msdn.com/sqlexpress/archive/2004/07/23/192044.aspx
    Try opening surface area configuration with admin privalages (like above) and try starting the sql server.

    If that fails install XP (ok thats a joke really i use Vista and would go back). [:)]

     

    Let me know how it goes

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, September 25, 2008 1:01 AM
  • User1988740161 posted

    Hi.  Thanks, I did follow your suggestion....sort of.  I turned off UAC in the control panel and tried going through the steps again.  No luck.  So I turned it back on.  I tried going through the steps  with "run as administrator" a couple of times.  No luck.  By this time I was just sort of randomly trying things, and then, suddenly it was running. Unfortunately, I don't know why.  I haven't shut down or restarted my computer since.  I'm pretty sure if I shut it down, the program will be stopped again.  So my problem is for the moment fixed.  Thanks

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Saturday, September 27, 2008 1:13 PM