locked
Read More link on Blog in SP2010 RRS feed

  • Question

  • Hi Guys,

     

    I am trying to get a read more... link on my blog posts.

     

    I see various solutions for 2007, but cant find one for 2010, anyone get any suggestions.

     

    regards,

     

    Chris


    Regards, Chris
    Monday, May 2, 2011 11:45 AM

Answers

All replies

  • could this provide some insight ?
    http://www.howtoinblogger.com/search/adding-read-more-link-in-sharepoint-2010-blogs/
    Regards, Marijn Somers|| SharePoint Consultant- MCTS SharePoint 2007, 2010 configuring http://www.beyond-it.be || Twitter: http://twitter.com/marijnsomers || http://marijnsomers.blogspot.com
    Monday, May 2, 2011 1:49 PM
  • as far as i can tell there is no content there?
    Regards, Chris
    Tuesday, May 3, 2011 10:36 AM
  • You can add/display 'teaser' content and a 'read more' link within a SP 2010 blog by modifying the blog.xsl file that is natively in the _layouts folder.

    If you create a column in the 'Posts' list named 'teaser' you can call this from the XSL file:

            <xsl:if test="$ShowBody=1">
           

              <div class="ms-PostBody">
                <div>
                  <xsl:value-of select="$thisNode/@teaser" disable-output-escaping="yes"/>
                    <a href="{$HttpVDir}/{$thisNode/../@resource.wss.lists_Folder}/{$thisNode/../@resource.wss.blogpost_Folder}/Post.aspx?ID={$thisNode/@ID}">

                    <span class="read-more">Read more</span></a>
                </div>
              </div>
            </xsl:if>

    This will display the 'teaser' content and create a link that will direct users to the full post where the body content will be displayed.

     

    Hope this helps.

     



    Friday, May 13, 2011 5:58 PM
  • I just posted a how too here... http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010customization/thread/a34d25ef-7a20-4ccf-aa1e-02b09de22a4f
    Heather Waterman SharePoint Desginer www.heatherwaterman.com
    • Marked as answer by Chris Grist Friday, May 20, 2011 11:45 PM
    Friday, May 13, 2011 8:12 PM
  • I just posted a how too here... http://social.msdn.microsoft.com/Forums/en-US/sharepoint2010customization/thread/a34d25ef-7a20-4ccf-aa1e-02b09de22a4f
    Heather Waterman SharePoint Desginer www.heatherwaterman.com


    Hi,

    i get this error, which is present everytime i save the page, until i have authenticated against the page.

    i.e. save page

    visit site as annonymous - get error

    login to site as admin users - all ok

    all ok for annonymous user as well:

    Access denied. You do not have permission to perform this action or access this resource.


    Regards, Chris
    Sunday, May 15, 2011 12:53 AM
  • Did this work before you made any change?
    Heather Waterman SharePoint Desginer www.heatherwaterman.com
    Monday, May 16, 2011 1:15 PM
  • Yes of course,

    it has also been fine ever since, all it takes is a logged in user to log in once and then its fine.

    I am using hosted provider so i cant IISReset, i just wonder that when the server is rebooted or reset, that the error may occur until its re authenticated again.


    Regards, Chris
    Tuesday, May 17, 2011 9:12 AM