none
Compiler Error Message: CS0433 on windows 8 RRS feed

  • Question

  • 0

    I have a Visual Studio 2010 solution using Microsoft ReportViewer.  It compiles on windows 7 but not on windows 8.

    It fails with the following:

    Compiler Error Message: CS0433: The type 'Microsoft.Reporting.WebForms.ReportDataSource' exists in both 'c:\Windows\assembly\GAC_MSIL\Microsoft.ReportViewer.WebForms\9.0.0.0__b03f5f7f11d50a3a\Microsoft.ReportViewer.WebForms.dll' and 'c:\Windows\assembly\GAC_MSIL\Microsoft.ReportViewer.WebForms\10.0.0.0__b03f5f7f11d50a3a\Microsoft.ReportViewer.WebForms.dll'

     

    I have the following in the web.config to no avail.

        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity  name="Microsoft.ReportViewer.WebForms" publicKeyToken="b03f5f7f11d50a3a"/>
            <bindingRedirect oldVersion="9.0.0.0-9.1.0.0" newVersion="10.0.0.0" culture="neutral" />
          </dependentAssembly>
        </assemblyBinding>
        <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
          <dependentAssembly>
            <assemblyIdentity  name="Microsoft.ReportViewer.WebForms" publicKeyToken="b03f5f7f11d50a3a"/>
            <bindingRedirect oldVersion="9.0.0.0-9.1.0.0" newVersion="10.0.0.0" culture="neutral" />
          </dependentAssembly>
        </assemblyBinding>

    Is there a way around this issue?


    Ben Levy

    • Moved by Bob Shen Tuesday, March 5, 2013 5:39 AM
    Monday, March 4, 2013 11:47 PM

All replies