locked
This project is incompatible with this version of VS RRS feed

  • Question

  • User2029 posted

    Xamarin 3.6.197.0 (ios 7.9.21.0): when i load a solution containing PCL projects (profile 49), those projects are not opened and instead they are marked "incompatible." ...

    Wednesday, September 10, 2014 10:10 PM

All replies

  • User112 posted

    Same here, one Profile7 is loading others are not for some reason.

    Thursday, September 11, 2014 6:36 AM
  • User112 posted

    Fun test. Create new project, add PCL, everything is fine. Reopen project and bum - incompatible.

    Thursday, September 11, 2014 6:40 AM
  • User112 posted

    The project is incompatible with the current edition of Visual Studio

    That's exact message from Solution Explorer.

    Thursday, September 11, 2014 6:41 AM
  • User112 posted

    Xamarin Studio doesn't have these problems, looks like on Visual Studio is affected.

    Thursday, September 11, 2014 6:43 AM
  • User112 posted

    Filled a bug report 22856

    Thursday, September 11, 2014 6:48 AM
  • User60257 posted

    Got the same problem. I wonder if Xamarin actually employ any testers on their VS team as every release breaks something. I really think they should change their pricing to give VS away for free, the extra cost is a joke for a product that is in such a bad state.

    Thursday, September 11, 2014 9:35 AM
  • User24226 posted

    I have the same problem with Profile78. Worst of all, I now can't develop WindowsPhone/Windows8/MonoDroid stuff either. I know it's beta but this clearly hasn't been tested properly for something this obvious and severe to slip through the net.

    Thursday, September 11, 2014 10:09 AM
  • User51765 posted

    Same Problem here with the Beta and Alpha Build.

    Thursday, September 11, 2014 11:36 AM
  • User24226 posted

    The bug has been confirmed by the testing company that Xamarin outsource to (https://bugzilla.xamarin.com/show_bug.cgi?id=22856) but I'm not sure exactly what that means in terms of getting it fixed as I've reported a bug with mono's implementation of DateTime.Now and it's been confirmed a week ago but no fix is planned?!

    Thursday, September 11, 2014 12:05 PM
  • User63744 posted

    Same here. All my PCL projects fail to open. Can't do anything now. This is ridiculous.

    And all I did was to follow this latest-and-greatest blog post http://blog.xamarin.com/xamarin-ios-8/

    Thursday, September 11, 2014 12:29 PM
  • User24142 posted

    Yup . I installed the latest beta so I could be ready for the ios8 webinar and now I'm having the same issue.

    Thursday, September 11, 2014 2:57 PM
  • User2029 posted

    a workaround is available in bugzilla

    Friday, September 12, 2014 6:43 AM
  • User24226 posted

    The workaround doesn't seem to be working for me - and I've changed all profiles, not just Profile78 (or Profile7 as some were reporting).

    Friday, September 12, 2014 8:04 AM
  • User1549 posted

    Likewise, the workaround worked for one of my PCL's but not another. A profile 136 loaded after the workaround but a profile 7 in the same solution still won't load.

    Friday, September 12, 2014 1:27 PM
  • User20824 posted

    Our team is also halted here. The bug that MihaMarkic reported is marked as fixed - is this fix going to be on the alpha channel soon or is that going to remain broken too? QA on the visual studio toolset has often been particularly poor IMO.

    Edit: Forgot to add that the workaround in the bugzilla just creates errors like: "The type 'System.Object' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Runtime, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.(...)"

    Friday, September 12, 2014 8:38 PM
  • User13824 posted

    One small update: a workaround for the "The type 'System.Object' ..." error has now been added the bug report as well. https://bugzilla.xamarin.com/show_bug.cgi?id=22856#c26

    Saturday, September 13, 2014 12:54 AM
  • User521 posted

    Ditto using PCL Profile111. Will this be fixed quickly on the Beta channel? (I don't want to switch to the Alpha channel.)

    Sunday, September 14, 2014 2:36 AM
  • User2029 posted

    Not fixed in 3.6.223.0

    Tuesday, September 16, 2014 5:04 PM
  • User20824 posted

    And after the last update in beta channel, running my PCL project in the debugger from Xamarin Studio - none of the breakpoints trigger. WTH with this release? I'm not fond of poking around editing stuff in my reference assembly folders because one day I will have to undo all that junk. I need an ETA on this series of screw-ups being fixed :|

    Tuesday, September 16, 2014 6:52 PM
  • User48769 posted

    This has been fixed in the latest build we pushed to the beta channel, 3.6.245.

    We will have a separate installer that will enable PCL and NuGet support for Xamarin.iOS Unified API projects, since that requires an update to the Microsoft NuGet Package Manager which is in alpha state still.

    Friday, September 19, 2014 5:04 AM
  • User20824 posted

    Thanks for the update, Daniel! I'll try it out shortly... I'll be sure not to run the separate installer for now though :)

    Friday, September 19, 2014 3:08 PM
  • User44660 posted

    Installed 3.6.245 this morning and BOOM no usable ios projects any more. This stinks! It's supposed to be a "stable" release. My PCL is the only project of 3 in the solution which loads. Dan (of Xamarin?) comments that this is all fixed in this release, did anyone actually test it? [Edit] Actually I just re-read his post and it says "pushed to beta channel". I don't use beta, just "stable" releases so how come this has been installed though automatic updates?

    Saturday, September 20, 2014 10:13 AM
  • User7593 posted

    @JohnBotibol Yup, the 3.6.245 release stinks. We have the same problem.

    what kind of STABLE release it is??

    3.7.126 got the same problem.

    Saturday, September 20, 2014 7:19 PM
  • User75441 posted

    I just got done updating to the latest "stable" version of the software on my mac and pc. Visual Studio/Xamarin "Synced" the iOS SDK and now my iOS project won't load anymore. Says that it's an unsupported project file. The other projects load including the shared project, but when ever I try to open a file I get the unsupported project file message.

    Saturday, September 20, 2014 7:30 PM
  • User521 posted

    I've also updated to the latest beta channel on both Mac (XS 5.4 build 240, Xamarin.iOS 8.0.0.62) and PC (Xamarin 3.6.245.0, Xamarin.iOS 8.0.52.0), and sync'ed the iOS SDK, but still get the error.

    @kzu are there some other steps required?

    Saturday, September 20, 2014 8:22 PM
  • User7593 posted

    xamarin, fix it asap.

    Saturday, September 20, 2014 8:41 PM
  • User13824 posted

    I think this problem with iOS projects is something new. It sounds like it might be an issue where the installer isn't replacing all the files it should. I'm investigating a bit now so that the developers will hopefully be able to solve it straight away on Monday.

    To make it easier to keep the iOS project load problem distinct from the PCL problem, for anyone seeing the iOS problem, let's move the reports about that to the other thread here:
    http://forums.xamarin.com/discussion/24316/ios-project-is-unsupported

    Sunday, September 21, 2014 3:13 AM
  • User35993 posted

    I'm 'having the same problem using the latest version of the beta channel as of 9/24, any updates on this?

    Wednesday, September 24, 2014 6:10 PM
  • User13824 posted

    @Abski, replied on the other thread: http://forums.xamarin.com/discussion/comment/78371/#Comment_78371

    Wednesday, September 24, 2014 6:16 PM
  • User6236 posted

    I have a similar issue when I upgraded to Xamarin 3.8.150. However if I change to the alpha channel (3.9.65) the problem goes away.

    Tuesday, November 25, 2014 9:08 PM
  • User521 posted

    @spdjackson? Xamarin 3.8.150 works okay for me. Are you using the latest Nuget?

    Wednesday, November 26, 2014 4:43 AM
  • User37696 posted

    Hey All,

    For anyone still running into this issue with 3.8.150, please try updating your NuGet Package Manager.

    Wednesday, November 26, 2014 9:45 PM
  • User6236 posted

    I think on am on latest. Package Manager Console Host Version 2.8.50926.663

    If I change to alpha channel it all works as expected

    Thursday, November 27, 2014 3:00 AM
  • User2029 posted

    uninstall xamarin / reboot / reinstall xamarin

    Thursday, November 27, 2014 5:42 AM
  • User91545 posted

    Hi guys,

    This errors is annoying me, everytime I need to close my VS2013 I have to reinstall Xamarin to normalize the situation spending about 1 hour.

    Is there any workaround?

    I'm using VS2013, Xamarin 3.8.150.0, Nuget Package Manager 2.8.50926.663

    Monday, January 5, 2015 1:47 PM
  • User59024 posted

    I'm also looking for workaround that will solve this issue. It's very frustrating. And I'm only trying to open my project in VS because the component store won't load correctly when using Xamarin Studio on OS X. Blarg, I would love to feel like I can make some progress with this product without trying to solve Xamarin issues 50% of the time.

    Wednesday, January 28, 2015 11:14 PM
  • User23053 posted

    OK - Xamarin owes us an explaination of this issue. I too have am getting this issue on PCL projects that worked fine for ever. It is definitely a XAM issue. Can uninstall XAM and VS begins to recognize PCL projects again. Upon install of XAM, you can create Xam PCL App Template solution, will compile just fine. Save. Then try and reload, and PCL project wont load, and is marked as Incompatible. Profile 79 I have another VS install on MAC, and never upgrade. Works fine. Very frustrating.

    Monday, February 2, 2015 9:57 PM
  • User8490 posted

    workaround doesn't work for me either even when changing all profiles.

    Monday, March 9, 2015 8:36 PM
  • User8490 posted

    the workaround doesn't work for me either, even after changing all profiles.

    Monday, March 9, 2015 8:36 PM
  • User220400 posted

    This is the solution: http://stackoverflow.com/questions/17596543/error-message-no-exports-were-found-that-match-the-constraint-contract-name

    Thursday, September 1, 2016 9:11 AM
  • User48769 posted

    Clear MEF Component Cache fixes it consistently for me: https://visualstudiogallery.msdn.microsoft.com/22b94661-70c7-4a93-9ca3-8b6dd45f47cd

    Thursday, September 1, 2016 4:25 PM
  • User300023 posted

    Just updated my VS 2017 and now my droid and ios projects display this error message. Here is the full error message

    Unsupported This version of Visual Studio is unable to open the following projects. The project types may not be installed or this version of Visual Studio may not support them. For more information on enabling these project types or otherwise migrating your assets, please see the details in the "Migration Report" displayed after clicking OK. - MyProject.Droid, "C:\MyPathToProject"

    Non-functional changes required Visual Studio will automatically make non-functional changes to the following projects in order to enable them to open in Visual Studio 2015, Visual Studio 2013, Visual Studio 2012, and Visual Studio 2010 SP1. Project behavior will not be impacted. - MyProject.Droid, "C:\MyPathToProject"

    "Migration Report": The application which this project type is based on was not found. Please try this link for further information: http://go.microsoft.com/fwlink/?LinkID=299083&projecttype=EFBA0AD7-5A72-4C68-AF49-83D382785DCF

    The link redirects here: https://www.xamarin.com/visual-studio

    Any help will be greatly appreciated.

    Tuesday, May 16, 2017 11:00 AM
  • User357139 posted

    Go to ‘Uninstall Or Change a Program Window’ {“Control Panel\Programs\Programs and Features”}, Find ‘Visual Studio 2015 Tools for Xamarin’ And Repair It.

    It solved my problem :smile:

    Friday, September 28, 2018 11:25 AM