none
Move VHDs from standard to premium storage

    Question

  • Hi guys,

    Anyone know of a tool or an easy way to move my VHDs from standard storage to premium storage?

    I have a standard storage account with 6 containers and VHDs inside. I would like to move all of them, in the same structure to premium storage.

    Is it possible?

    If I use the same code that allows me to copy vhds from std to std storage, that works, when the target is premium storage I get error 404 file not found.

    Thanks.


    Regards, Shai Petel.

    Tuesday, December 1, 2015 7:58 PM

Answers

  • Figured it out in case someone else is wondering...

    I went into my standard storage container and changed the access policy from "private" to "blob", meaning my blobs are now open to public / anonymous.

    Now, I run the same code and the VHD moved with no problem!


    Regards, Shai Petel.

    • Marked as answer by Shai Petel Tuesday, December 1, 2015 8:06 PM
    Tuesday, December 1, 2015 8:06 PM

All replies

  • Figured it out in case someone else is wondering...

    I went into my standard storage container and changed the access policy from "private" to "blob", meaning my blobs are now open to public / anonymous.

    Now, I run the same code and the VHD moved with no problem!


    Regards, Shai Petel.

    • Marked as answer by Shai Petel Tuesday, December 1, 2015 8:06 PM
    Tuesday, December 1, 2015 8:06 PM
  • I would not encourage you to make those containers\blobs public.

    Instead, you should use SAS policies on your standard storage blobs, and copy using SAS url to premium storage.

    Tuesday, December 1, 2015 9:08 PM
  • Figured it out in case someone else is wondering...

    I went into my standard storage container and changed the access policy from "private" to "blob", meaning my blobs are now open to public / anonymous.

    Now, I run the same code and the VHD moved with no problem!


    Regards, Shai Petel.

    What are you using to copy Blobs between SA ?

    Regards, Samir Farhat || Datacenter Consultant || The way to share my knowledge with the community Visit my blog : buildwindows.wordpress.com buildwindows.wordpress.com </a>

    Wednesday, December 2, 2015 9:51 AM
  • I used my own C# code, and azure storage explorer 6.

    Both failed with same error before, both working now that I opened it.


    Regards, Shai Petel.

    Wednesday, December 2, 2015 4:50 PM
  • but it doesnt do me any good, since I can't use them with classic VMs, I have to use them with new type VMs and I already have a tool that provisions farms based on the classic VMs...

    (Insert sad face here)


    Regards, Shai Petel.

    Wednesday, December 2, 2015 4:51 PM