none
Visual Studio (2010 & 11) keep referencing the .net 4 assemblies, even after .net 4.5 is installed. RRS feed

  • Question

  • .Net 4.5 installs to the directory

    C:\Windows\Microsoft.NET\Framework\v4.0.30319

    Visual Studio 2010 installs .Net 4.0 to the directory

    C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.0

    Even if .Net 4.5 is installed prior to VS 2010.  Now, no matter what I do, both VS 2010 and VS 11 keep referencing the assemblies in C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.0, even if I remove the assembly from the project, and add the assembly by browsing to the 4.5 directory (C:\Windows\Microsoft.NET\Framework\v4.0.30319)

    How do I get Visual Studio to reference the .Net assemblies located here C:\Windows\Microsoft.NET\Framework\v4.0.30319 ??

    Thanks


    Friday, March 9, 2012 3:49 PM

Answers

  • Hi Gary,

    Have you updated the "Target framework" version and select .Net 4.5 in project properties' Application tab?

    Helen Zhou [MSFT]
    MSDN Community Support | Feedback to us

    • Edited by Helen Zhou Monday, March 12, 2012 4:44 AM
    • Marked as answer by Helen Zhou Monday, March 26, 2012 9:41 AM
    Monday, March 12, 2012 3:47 AM

All replies

  • Hi Gary,

    Have you updated the "Target framework" version and select .Net 4.5 in project properties' Application tab?

    Helen Zhou [MSFT]
    MSDN Community Support | Feedback to us

    • Edited by Helen Zhou Monday, March 12, 2012 4:44 AM
    • Marked as answer by Helen Zhou Monday, March 26, 2012 9:41 AM
    Monday, March 12, 2012 3:47 AM
  • Hi Gary,

    If you feel the solution I gave doesn’t real answer your question, please feel free to unmark it and update the thread.

    Regards,


    Helen Zhou [MSFT]
    MSDN Community Support | Feedback to us

    Monday, March 26, 2012 9:42 AM