none
Entity Data Model not showing in datasources RRS feed

  • Question

  • Hello

    I am trying to add an 'Entity data model' data source in a new project.  When I use the "Add New Data Source" wizard in VS 2010 it works as expected, when I use VS 2012 the wizard finishes without errors but there are still no data sources in the "Data sources" pane.  I have tried creating a dataset and it shows up fine.  Am I missing something?  The steps I follow are here:

    http://msdn.microsoft.com/en-us/library/dd465159.aspx

    This walkthrough says it is for VS 2012 but it mentions the Data menu which no longer exists.

    I am using Windows 8 64bit and VS 2012 professional.

    Thank you in advance

    Serafim

    • Moved by Youen Zen Monday, December 3, 2012 5:17 AM Appropriate forum for this issue (From:Visual Studio Class Designer)
    Saturday, December 1, 2012 11:07 AM

Answers

  • Hi Serafim,

    Welcome to the MSDN forum.

    Could you see the Data Source window on the left of Visual Studio which is auto hide generally?

    If you could not, please try this: Click View on the menu>>Other Windows>>Data Sources. After you open the Data Source window, click the Add New Data Source on this window.

    I think there is some mistakes on the page you provide. If you don’t mind, you can check my steps after you add entity data model into your project:

    • Click Add New Data Source to open the Data Source Configuration Wizard again.
    • On the Choose a Data Source Type page, click Object, and then click Next.
    • Expand the node whose name is the same as your project.
    • Enable the tables you want to add to Data Source.
    • Click Finish.

    Then you should be able to find the corresponding things in DataSource.

    Have a nice day.


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Serakar Monday, December 3, 2012 3:27 PM
    Monday, December 3, 2012 8:40 AM

All replies

  • Hi Serafim,

    Thanks for your post.  We have a forum ADO.NET Entity Framework and LINQ to Entities discuss this issue. In order to provide better support, I will move this thread.

    Best regards,


    Shanks Zen
    MSDN Community Support | Feedback to us

    Monday, December 3, 2012 5:16 AM
  • Hi Serafim,

    Welcome to the MSDN forum.

    Could you see the Data Source window on the left of Visual Studio which is auto hide generally?

    If you could not, please try this: Click View on the menu>>Other Windows>>Data Sources. After you open the Data Source window, click the Add New Data Source on this window.

    I think there is some mistakes on the page you provide. If you don’t mind, you can check my steps after you add entity data model into your project:

    • Click Add New Data Source to open the Data Source Configuration Wizard again.
    • On the Choose a Data Source Type page, click Object, and then click Next.
    • Expand the node whose name is the same as your project.
    • Enable the tables you want to add to Data Source.
    • Click Finish.

    Then you should be able to find the corresponding things in DataSource.

    Have a nice day.


    Alexander Sun [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Marked as answer by Serakar Monday, December 3, 2012 3:27 PM
    Monday, December 3, 2012 8:40 AM
  • Thank you very much for your answer, your solution worked.  VS2012 needs those extra steps, while VS2010 adds the data source automatically after you finish creating it.

    Serafim

    Monday, December 3, 2012 3:27 PM