locked
Unable to process the cube RRS feed

  • Question

  • Hi,

    when trying to process a cube, i get a strange message saying that a device attached to the system is not functioning. 

    I am new to it and this is just a simple cube based over Adventure Works.

    Please advise.

    Thank you

    • Edited by Octopus02 Sunday, August 9, 2020 2:42 PM
    Sunday, August 9, 2020 1:06 PM

All replies

  • Hi,

    This could be an issue with the SQL Server or SSAS account.

    Please try set as this thread posted : Processing cube -Error-A device attached to the system is not functioning

    Hope this helps.

    Regards,

    Lukas


    ""SQL Server related"" forum will be migrated to a new home on Microsoft Q&A SQL Server!
    We invite you to post new questions in the "SQL Server related" forum’s new home on Microsoft Q&A SQL Server !
    For more information, please refer to the sticky post.

    Monday, August 10, 2020 2:44 AM
  • Thank you for the link.

    He is suggesting to change the Locale and LocaleName in the Registry.

    I have done that using the registry editor of win 10 and restarted.

    However the error message remains unchanged. 

    "A device attached to the system is not functioning."

    SO i am unable to process a cube or a dimension.

    Monday, August 10, 2020 8:38 AM
  • Hi,

    Did you get any other info from Event Viewer or profiler?

    As I did some search on internet , multiple user reports it should be Locale related.

    Worst case is , could you try reinstall the SSAS service?

    Did you have problems running with SSMS?


    ""SQL Server related"" forum will be migrated to a new home on Microsoft Q&A SQL Server!
    We invite you to post new questions in the "SQL Server related" forum’s new home on Microsoft Q&A SQL Server !
    For more information, please refer to the sticky post.

    Tuesday, August 11, 2020 7:11 AM