locked
Web page Popup - The playback failed to find the control with the given search properties RRS feed

  • Question

  • Hi,

    I'm also having issues with CodedUI Web page testing where a popup has opened for a search screen but the test fails to continue with controls on the popup page. I've tried most of the suggestions (SearchConfiguration.Any, OrderofInvocation, made sure popup is not in a tab) but still not working. Any other tips would be helpful.

    Thanks,

    Simon

    Error is:

    "UITestControlNotFoundException: The playback failed to find the control with the given search properties. Additional Details:
    TechnologyName:  'Web'
    ControlType:  'Frame'
    TagName:  'FRAME'
    Id:  'searchFrame'
    Name:  'searchFrame'
     Failed to find any control that matched the search condition Id='searchFrame' && Name='searchFrame' && ControlType='Frame' ---> System.Runtime.InteropServices.COMException: Error HRESULT E_FAIL has been returned from a call to a COM component."

    Saturday, April 7, 2012 5:31 AM

Answers

All replies

  • Hi simmohall,

    Thank you for posting in the MSDN forum.

    "UITestControlNotFoundException: The playback failed to find the control with the given search properties. Additional Details:

    TechnologyName:  'Web'

    ControlType:  'Frame'

    TagName:  'FRAME'

    Id:  'searchFrame'

    Name:  'searchFrame'

    Failed to find any control that matched the search condition Id='searchFrame' && Name='searchFrame' && ControlType='Frame' ---> System.Runtime.InteropServices.COMException: Error HRESULT E_FAIL has been returned from a call to a COM component.

    When the SearchProperties of the control are not good enough or the serach condition for the control is changed automatically, it will generate this issue.

    Paul gave us some suggestion about how to handle this issue, if possible, please refer:

    The playback failed to find the control with the given search properties. Additional Details:

    Error running the Coded UI test

    This is a blog about “Troubleshooting Record and Playback issues in Coded UI Test”, and you could check your test with the steps in this blog. Hope it can help.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, April 10, 2012 5:46 AM
    Moderator
  • Hi  Simmohall,

    Have you managed to resolve the issue with finding controls on popup windows. If so, could you please share you knowledge?

    Thanks


    • Edited by softsols Friday, November 16, 2012 3:52 PM
    Friday, November 16, 2012 3:51 PM