none
Using ICE to set up the Screen Resolution RRS feed

  • Question

  • I want to set up the screen resolution for our target in ICE and have made those changes, but they never seem to work.  I have modified both the Display properties in Product->Operating System->Foundation Core->Windows Embedded Edition->Shell-Setup_x86 at the OOBE pass and the Display properties under Setup_x86 at the WindowsPE pass.  It seems to ignore both.  I would expect that the settings made in Shell Setup in OOBE are the ones I want.  I used the same settings for the WinPE Setup (but no DPI setting).   

    I set:

    ColorDepth to 32

    RefreshRate to 60

    HorizontalResolution to 1024

    VerticalResolution to 1280

    DPI to 96.

    The end goal here is to have the flt panel running in portrait mode 1024x1280. 

    What could I be doing wrong? I'd appreciate any help you could give me here!

    Thanks,

    Rick

    Wednesday, June 9, 2010 6:01 PM

All replies

  • Thanks Ivan.  Actually, I saw that thread yesterday and posted my question to it.  I thought that maybe it would be lost there so I decided to post in a new thread today.  As you can see in my explanation, I know about the settings, but they do not work.  I was hoping that there was some other simple thing I missed.  Right now I have to manually set them in the control panel, which I do have working.  So my problem is the exact opposite of Jake3888's. 

    Any ideas?

    Rick

    Wednesday, June 9, 2010 8:55 PM
  • Rick, could you try something for me?  Add your settings to all passes (P4, 5, 6, 7) and see if you get the expected resolution on the runtime.

    Ivan

    Wednesday, June 9, 2010 11:36 PM
  • I have the same problem, just in landscape mode, 1280 x 1024.  I've put the same setting in every pass (P4, P5, P6, P7) and also P1.  It appears to look correct during installation.  It just doesn't get it correct in the final OOBE pass.

    The only other difference in my settings is that I don't specify the DPI (left blank).

    This was actually working properly in the CTP release, but not in the RC1 and now RTM release.

    Thursday, June 10, 2010 12:37 AM
  • OK, I will try that.  I already had it under P4 and P7 under Shell_Setup and P1 under Setup.  I didn't even think that P5 and P6 ran during a normal install so I didn't try that (yet).  Although it sounds like joeEmbded has not had luck with this method.  I'm currently running RC1.  I just DLed RTMthe other dya, but have not had a chance to re-install everything yet.  Unlike him, I haven't even seen this work during installation.
    Friday, June 11, 2010 2:17 PM
  • Ivan,

    I just tried that and it didn't work at all. Perhaps you would know the registry settings that I could use to automate this process though a .reg file?  Thanks!

    Rick

    Friday, June 11, 2010 5:20 PM
  • Any further ideas?  I now have it so that it is setting the resolution to 1280x1024 (even though I specify 1024x1280).  It seems to kick in during the Specialize phase and then sticks, but it does not get the orientation correct.

    Do you know the registry settings I could use to set the resolution and the screen orientation?  This would be completely acceptable with me too. I've got my image deployment almost 100% automated now and would like to get it the rest of the way.  I alreadty have a .reg file with custom tweaks in it that gets applied as a Synchronous Command during OOBE.  Adding a few more entries would not hurt anything.

    Tuesday, June 15, 2010 5:32 PM
  • Rick, I personally have not modified resolution settings through registry.  Searching through internet, I've seen quite a few places that talks about changing resolution through registry so you might want to try that.  We will try this internally and file a bug.  Thank you for reporting this issue to us.

    Ivan

    Tuesday, June 15, 2010 6:54 PM
  • Ivan,

    Thanks for the response. I will look around for the registry settings. 

    OK, sounds good.  You're welcome.

    Rick

    Tuesday, June 15, 2010 8:28 PM
  • See my solution at

    http://social.msdn.microsoft.com/Forums/en/quebecservicingdeployment/thread/45d0098a-701b-4f18-964f-5bee3e78ee84

    I found that my graphics driver defaults to duplicate mode.  So I needed to switch it to projector only because any attempt at changing the screen resolution would take hold.

    Hope this helps.


    Joe Leong
    Thursday, February 24, 2011 2:33 AM