none
EDI Schema Editor Extension problem RRS feed

  • Question

  • Hi,

    I have a schema that I migrated from BizTalk 2002 (XDR schema format) to XSD format via Visual Studio 2005.

    (i.e. renamed the schema from .xml extension to .xsd, included in new BizTalk project and opened in VS which performed automatic conversion).

     

    The schema gets converted without any errors. By default after migration, the Schema Editor Extensions property (on <Schema> node) has nothing selected in the list.

    To test the schema I want to  generate a native instance and this requires selecting the EDI schema Extension Editor.

     

    The problem is after I select the EDI Schema Editor Extension as the editor and try Validate Schema I get the following error:

     error BEC2004: Object reference not set to an instance of an object.

     

    The same error occurs when trying to Generate Instance. If I remove the EDI Schema Editor and validate the schema without any editors, it validates fine. The XML seems to be valid.

     

    Why can't I use the new EDI Schema Editor extension with my migrated schema?

    Can anyone assist with this issue?

     

    I can provide the schema via email if required.

    Thanks,

    Sergiy

    Wednesday, August 29, 2007 5:32 AM

Answers

All replies

  • Did you try to rebuild the project?
     
    Regards,
     
    Leonid Ganeline
     
    Wednesday, August 29, 2007 6:17 PM
  • Thanks for your reply, Leonid.

     

    Yes I tried rebuilding the project. It compiles fine without the EDI Schema Editor Extension, but I get a compile error "Object reference not set to an instance of an object" when it's selected.

     

    There's nothing in the event log, so I'm not sure how to troubleshoot it further. The error message I'm getting is not very helpful.

     

     Another thing to note is that I tried using the EDI schemas out of the box that come with R2. I was able to Validate, Generate Instance and compile one of these EDI schemas without any probs.

     

    Maybe there's something missing in my migrated schema that won't let me use the MS EDI Schema Editor extension. And since I can't get it to work at design-time (i.e. generate instance in VS2005) it won't work at BizTalk runtime (i.e. assemble EDI) .

     

    Could there be something to do with encoding or something else that out of the box schemas have, which is not in my migrated schema?

     

    Sergiy

    Wednesday, August 29, 2007 11:11 PM
  • My knowledge of schema migration is limited, but I suspect the process of migration you followed (renaming and automatic conversion performed by VS) might not be the one used.

     

    Lets see if someone else on this forum can contribute more to this

     

    Thanks

    Mohsin

     

    Wednesday, August 29, 2007 11:20 PM
  • I propose to "Open with..." the schema from the XML schema editor. Then try to use the one of the out-of-box EDI R2 schemas as an example and change your schema hi level attributes to follow this example.
     
    Regards,
     
    Leonid Ganeline
     
    Tuesday, September 4, 2007 10:12 PM