none
Exchange 2010 New-PSSession -ComputerName <exch_server> -UseSSL RRS feed

  • General discussion

  • Hello all - I am not sure about SSL and Exchange 2010.


    All I need to do is execute cmdlets using ssl. i.e create PSSession using ssl like below

    New-PSSession -ComputerName <exch_server> -UseSSL

    What all steps are required ? Please give me some pointers.

    Till now I have done

    • Installed AD certificate services with type as Enterprise Root CA.  And certificate common name is exactly same as exchange server host machine name
    • remote-pssession-over-ssl

    I always get below error

    <<

    [] Connecting to remote server failed with the following error message : The SSL connection cannot be esta
    blished. Verify that the service on the remote host is properly configured to listen for HTTPS requests. Consult the lo
    gs and documentation for the WS-Management service running on the destination, most commonly IIS or WinRM. If the desti
    nation is the WinRM service, run the following command on the destination to analyze and configure the WinRM service: "
    winrm quickconfig -transport:https". For more information, see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed

    >>

    Please let me know if I have missed anything. Thanks!

    A



    /M


    • Edited by user5796 Thursday, May 23, 2013 12:29 PM
    Thursday, May 23, 2013 12:23 PM

All replies

  • I was able to get through this error. The mistake was - I was using a self signed certificate. I requested for another cert and this error is gone now. But now i am getting

    [] Connecting to remote server failed with the following error message : Access is denied. F
    or more information, see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption

    In the event viewer for

    1. Windows Remote Management - I see event id 143 "Received the response from Network layer; status: 200 (HTTP_STATUS_OK)"
    2. and the followed by event id 129 "Received the response from Network layer; status: 401 (HTTP_STATUS_DENIED)"

    What could be the issue? Thanks.


    /M

    Saturday, May 25, 2013 7:59 AM