none
Can't connect to Azure File Storage share using 'net use'

    Question

  • I have been able to connect to my file storage container using net use from one of my azure vm's (the same way that described when you click the connect button in the azure portal).

    However as of a couple of days ago, it just stopped working.

    This seems to align to when my new billing month started. And i noticed that my MSDN subscription (which my azure account is linked to) had expired. I have now renewed my subscription, however it is still not working.

    One thing that i notice is that i can connect to it fine from my own machine (using the same command), just not from any of my azure VMs.

    the command i am using is:

    net use I: \\tmxaitsharedstorage.file.core.windows.net\installpackages /u:tmxaitsharedstorage [storage key]

    (obviously i put my storage key in there, i just don't want to put it on the internet :p)

    Thursday, June 23, 2016 12:06 AM

Answers

  • Are you using classic VM, or in the new portal?

    For classic VM - http://www.microsofttrends.com/2015/03/30/internet-access-from-azure-vm-not-working-problem-solved/

    for ARM (new) VM - try set the DNS to "Azure DNS" on the network interface attached to your VM. If that doesn't work, try custom DNS and use something like google's 8.8.8.8


    If this post was helpful, please click the up arrow or propose as answer.

    • Proposed as answer by Nick HogarthMVP Thursday, June 23, 2016 4:43 AM
    • Marked as answer by MattFenner Thursday, June 23, 2016 5:57 AM
    Thursday, June 23, 2016 4:13 AM

All replies

  • Hi Matt. Can your Azure VM's DNS resolve the name of the stoage account? ie tmxaitsharedstorage.file.core.windows.net


    If this post was helpful, please click the up arrow or propose as answer.

    Thursday, June 23, 2016 3:29 AM
  • I'm not quite sure how to test this. but pinging doesn't work, neither does putting \\tmxaitsharedstorage.file.core.windows.net\installpackages into the address bar of windows explorer

    in both cases it says it cannot access/find the host

    Thursday, June 23, 2016 3:43 AM
  • Is the mapped drive working from your own machine right now? If so, can you ping it?

    If this post was helpful, please click the up arrow or propose as answer.

    Thursday, June 23, 2016 3:45 AM
  • the mapped drive works from my own machine. but i can't ping it (generally i have found ping is turned off for most things in azure)
    Thursday, June 23, 2016 3:48 AM
  • On the Azure VM, if you do a nslookup from cmd like "nslookup tmxaitsharedstorage.file.core.windows.net"

    Do you get a response like:

    Non-authoritative answer:
    Name:    file.ml1prdstr02a.store.core.windows.net
    Address:  13.77.8.76
    Aliases:  tmxaitsharedstorage.file.core.windows.net

    Sounds like the azure file services is working if you can access it from your own machine, and seems like its a network issue if you're using the same command to map it to your azure vm but it doesn't work.


    If this post was helpful, please click the up arrow or propose as answer.

    Thursday, June 23, 2016 3:53 AM
  • i get:

    Server:  UnKnown
    Address:  168.63.129.16

    *** UnKnown can't find tmxaitsharedstorage.file.core.windows.net: Format error

    I agree with your assesment. It is strange that it was working and then stopped working all of a sudden without me changing anything though

    Thursday, June 23, 2016 4:10 AM
  • Are you using classic VM, or in the new portal?

    For classic VM - http://www.microsofttrends.com/2015/03/30/internet-access-from-azure-vm-not-working-problem-solved/

    for ARM (new) VM - try set the DNS to "Azure DNS" on the network interface attached to your VM. If that doesn't work, try custom DNS and use something like google's 8.8.8.8


    If this post was helpful, please click the up arrow or propose as answer.

    • Proposed as answer by Nick HogarthMVP Thursday, June 23, 2016 4:43 AM
    • Marked as answer by MattFenner Thursday, June 23, 2016 5:57 AM
    Thursday, June 23, 2016 4:13 AM
  • i am using classic.

    it was already set to the default DNS provider so i changed it to 8.8.8.8 and after restarting the VM this has fixed it.

    It's awesome that it's fixed now, but does that mean that the default azure DNS server is broken?

    p.s. i tried changing it back to the default one to check and it indeed was broken again with the default dns provider.

    Thursday, June 23, 2016 4:29 AM
  • It should provide Public DNS name resolution as well. Not sure why it didn't work.

    You can read up here on Azure DNS a bit more for classic machines - https://azure.microsoft.com/en-us/documentation/articles/virtual-networks-name-resolution-for-vms-and-role-instances/#azure-provided-name-resolution

    Cheers,

    Nick


    If this post was helpful, please click the up arrow or propose as answer.

    Thursday, June 23, 2016 4:47 AM
  • yes. it definitely was working before. very strange
    Thursday, June 23, 2016 4:53 AM