none
ASP.NET [.net framework 3.5 , designed by VS2010] not working in IIS6 [win server 2003] RRS feed

  • Question

  • hello , i have developed an ASP.net webpage and tested it in VS2010 , it loads without any error/problems . i uploaded the webpage and all of other files needed to my Windows server 2003 (with IIS6 , .Netframework 2 and 3.5) using Visual studio . when i browse to my webpage i see this error :

    Server Error in '/' Application.
    
    Runtime Error
    
    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 
    
    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
    
    
    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="Off"/>
      </system.web>
    </configuration>
    
    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
    
    
    <!-- Web.Config Configuration File -->
    
    <configuration>
      <system.web>
        <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
      </system.web>
    </configuration>

     i have edited the web.config file that has been uploaded with my site so custom errors has been set to OFF but i still see this page ...

    • Edited by Simon 96 Friday, August 26, 2011 3:58 PM error code wasn't shown properly
    Friday, August 26, 2011 3:52 PM

Answers

  • i've found the error myself ...

     

    i hadn't uploaded the default.aspx in the root folder . but i made that folder as an application not the folder i had uploaded the webpage in .

    • Marked as answer by Simon 96 Friday, August 26, 2011 4:44 PM
    Friday, August 26, 2011 4:44 PM

All replies

  • i have managed to turn off the custom errors 

    (from : IIS > right click website > ASP.NET > Edit Global configuration > Custom errors > custom error mode)

     

    now i get this instead (which is the real problem ...):

    Server Error in '/' Application.
    
    Configuration Error
    
    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately. 
    
    Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS.
    
    Source Error: 
    
    
    Line 37:    ASP.NET to identify an incoming user. 
    Line 38:   -->
    Line 39:   <authentication mode="Windows" />
    Line 40:   <!--
    Line 41:    The <customErrors> section enables configuration 
    
    Source File: C:\Site\kyokushin\fa\web.config  Line: 39 
    


    Friday, August 26, 2011 4:19 PM
  • i've found the error myself ...

     

    i hadn't uploaded the default.aspx in the root folder . but i made that folder as an application not the folder i had uploaded the webpage in .

    • Marked as answer by Simon 96 Friday, August 26, 2011 4:44 PM
    Friday, August 26, 2011 4:44 PM