locked
Jet Error on 64bit OS RRS feed

  • Question

  • User-356713555 posted

     Hello all,

    I have installed my web application on a customer site which is using a 64 bit Windows 2008 machine.

    The problem that I am having is that when the application tries to access a microsoft Access database it gets the following error:

    "Microsoft.Jet.OLEDB.4.0' provider is not registered on the local machine". I had this problem before on my development machine which is a Windows 7 64bit OS. What had to do is change the application pool to Enable  32 bit applications and it works fine. But I have done the same on the client machine and its not working.

    I have also download the client database to my machine and had no problem connecting to it. to do a test I disabled the 32bit application on my IIS and I could recreat the customer's problem. Enabling again works fine.

    Now my question is why it does not work on the customer's site? I have configure IIS the same way!

    Any ideas?

    Friday, September 24, 2010 6:42 AM

Answers

  • User-356713555 posted

    Hello all,

    thanks for your replies.

    I have figured out!

    Not only you need to enable 32bit apps on IIS but you have also ensure that the site is on the trusted site list on IE. Also make sure that the user account has Read/Execute and Read on the file.

    Thanks all. 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, September 28, 2010 5:10 AM

All replies

  • User1716267170 posted

    That seems strange. Usually, we just need to enable 32bit mode in application pool to run the provider correctly. But if this still can't resolve the problem, I suggest you to report it to Microsoft to get more help:

    http://connect.microsoft.com/visualstudio

    Thanks.

    Tuesday, September 28, 2010 4:21 AM
  • User-356713555 posted

    Hello all,

    thanks for your replies.

    I have figured out!

    Not only you need to enable 32bit apps on IIS but you have also ensure that the site is on the trusted site list on IE. Also make sure that the user account has Read/Execute and Read on the file.

    Thanks all. 

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, September 28, 2010 5:10 AM