none
Web application giving 404 not found error RRS feed

  • Question

  • Hi,
    I have 2 web applicaitons (Main site and My site) both were running perfectly in port 80. Since debug was not working even after attaching worker process, i tried to reset visual studio settings using command line tool. after that my web applications are not loading, even if i try to access from IIS, its showing 404 Not found error. i dont know whether its because of Visual studio settings reset or not. After IIS RESET / Application Pool reset also still i am getting the same error.

    I have 1 wfe and 1 ap server. I tried to create new web apllication, that also only accesible from AP server only. not from WFE server

    Can anyone please help me to get the web application running and also to get the debugging mode in visual studio for sharepoint solutions.

    • Edited by JojinMondoth Wednesday, February 1, 2017 4:31 AM More Info added
    Tuesday, January 31, 2017 7:54 PM

All replies

  • Are you able to Navigate your main [root]/subsite site also through browser  ? Please check your app-pool account credentials and reset IIS and try again.
    Tuesday, January 31, 2017 8:06 PM
  • HI,

    HTTP 404 mean that the IIS server can't redirect to the specific page !! When you launch IIS manager and browse to the Central Administration site, is it launches without any problems ?

    Can you browse the site with the LocalHost. Please check whether you can ping the server name.

    Like  browse using http://IP_ADDRESS:TCP_PORT/

    Where IP_ADDRESS is your web server ip address, and TCP_port is the tcp port for the web app

    Here also if you received 404 error message, could be a problem with your default page for the site collection

    Try to reset the IIS server using UI or command prompt again and see. Make sure all app pool and sites are started state in iis server.

    Check by going to run services.msc and make sure SharePoint admin and timer service is running, restart it again. Also check your farm admin account is not locked out.


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    Tuesday, January 31, 2017 8:08 PM
  • hi,

    Thanks for the reply.

    I tried to access the site using  http://IP_ADDRESS:TCP_PORT/ also. still not loading. IIS and services also i restarted.but same result.

    I have 1 wfe and 1 ap server. I tried to create new web apllication, that also only accesible from AP server only. not from WFE server. 

    Please help me

    Wednesday, February 1, 2017 5:00 AM
  • hi,

    Thanks for the reply.

    Applicationpools account credentials also rested. IIS and services also i restarted.but same result.

    I have 1 wfe and 1 ap server. I tried to create new web apllication, that also only accesible from AP server only. not from WFE server. 

    Please help me

    Wednesday, February 1, 2017 5:01 AM
  • Hi,

    Please check the ULS log and see the detailed information.

    For SharePoint 2013, by default, ULS log locates in
    "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\15\LOGS"

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Wednesday, February 1, 2017 7:14 AM
    Moderator
  • One update:

    New web application was not working, because port was not enabled. 

    But existing webpplicaiton is not working from any where.....

    i did iisreset, applicaiton pool , bindings verification etc...still not working

    Alternate access mapping also checked.....but not getting

    Wednesday, February 1, 2017 8:03 AM
  • in logs its showing file not found in the web applicaiton error is showing
    Wednesday, February 1, 2017 10:14 AM
  • Hi,

    If you have added the WFE server recently can you share the details about what Services are running on which server? You can check this by going to Central Admin – System Setting – Services on server, from here you can select the server name and it will list all the services stopped or started on your Wife server and app server based on the selected server.

    https://social.technet.microsoft.com/Forums/office/en-US/64433eec-fc68-4ad4-955f-966a7d48b6c1/which-services-to-run-on-wfe-v-app-servers?forum=sharepointadmin

    need to check first which server is configured to handle request if you have enabled the Windows Foundation Web application service on your both server you have to map the same IIS binding on both server.

    Check this article for IIS binding: http://stackoverflow.com/questions/14953322/sharepoint-2013-404-not-found-while-accessing-site-collection-from-outside

    Check these threads having similar issue : https://support.microsoft.com/en-us/help/2543306/sharepoint-2010-while-creating-a-new-web-application,-a-404-page-not-found-error-is-displayed-and-the-web-application-is-only-provisioned-on-the-local-server

    http://sharepoint.stackexchange.com/questions/26568/going-to-a-site-collection-homepage-gives-a-404


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful


    Wednesday, February 1, 2017 7:58 PM
  • Hi KrishnaKumar,

    Thanks for the support.

    I identified the actual issue. Root site collection got deleted for no reason. I restored it. then it started working. 

    Sunday, February 5, 2017 6:22 AM
  • Hi,

    Thanks for sharing the update, glade it resolved.


    KRISHANA KUMAR

    SharePoint Architect

    Mosstechnet-kk.com

     

    Please click "Mark As Answer" if this post solves your problem or "Vote As Helpful" if it was useful

    Monday, February 6, 2017 2:26 PM
  • Hi,

    Thanks for sharing! you can mark the reply as answer, it will make others who stuck with the similar issue easier to search for valid solutions in this forum.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, February 7, 2017 1:24 AM
    Moderator