none
MANAGE META DATA SERVICE CONNECTION - The authentication header received from the server was 'Negotiate,NTLM'. RRS feed

  • Question

  • I recently installed SP2010 in WIN 8.1 and all are working fine. I got an issue in Central Admin - when I go to Managed Metadata service - I get"The server Method 'Check Permission' failed".  (this ISSUE FIXED)

    I fixed this issue as per blogs.technet.com/b/sykhad-msft/archive/2012/02/25/sharepoint-2010-nailing-the-error-quot-the-security-token-service-is-unavailable-quot.aspx after this I was able to set up content hub and access manage meta data service. But today, after a restart, when I click "manage Meta Data service connection" and click properties - I get below error.

    I found few links but I don't know where to update (which config file) thanks for helping me.

    Request for security token failed with exception: System.ServiceModel.Security.MessageSecurityException: The HTTP request is unauthorized with client authentication scheme 'Negotiate'. The authentication header received from the server was 'Negotiate,NTLM'. ---> System.Net.WebException: The remote server returned an error: (401) Unauthorized.

    Monday, November 3, 2014 7:32 PM

Answers

All replies

  • UPDATE:

    I see below entries under Application host config file

    <location path="SharePoint Central Administration v4/_vti_bin/sts">
            <system.webServer>
                <handlers accessPolicy="Read, Execute, Script" />
                <staticContent>
                    <clientCache cacheControlMode="UseMaxAge" cacheControlMaxAge="365.00:00:00" />
                </staticContent>
                <security>
                    <authentication>
                        <windowsAuthentication enabled="false">
                            <providers>
                                <clear />
                               <add value="Negotiate" />
                                <add value="NTLM" />
                            </providers>
                        </windowsAuthentication>
                        <anonymousAuthentication enabled="true" />
                        <digestAuthentication enabled="false" />
                        <basicAuthentication enabled="false" />
                    </authentication>
                </security>

    and under web config of secure token service I see

    <system.webServer>
        <security>
          <authentication>
            <anonymousAuthentication enabled="true" />
            <windowsAuthentication enabled="true">
              <providers>
                <clear />
                <add value="Negotiate" />
                <add value="NTLM" />
              </providers>
            </windowsAuthentication>
          </authentication>
        </security>
        <modules>
          <add name="WindowsAuthenticationModule" />
        </modules>
      </system.webServer>

    Monday, November 3, 2014 9:15 PM
  • Hi SP Rookie,

    >>The HTTP request is unauthorized with client authentication scheme 'Negotiate'. The authentication header received from the server was 'Negotiate,NTLM'

    Before you get bogged down in the complexities of WCF bindings and IIS metadata, there may be a simple fix. If the client and service are on the same machine, please try to check out this article:

    http://blogs.msdn.com/b/distributedservices/archive/2009/11/10/wcf-calling-wcf-service-hosted-in-iis-on-the-same-machine-as-client-throws-an-authentication-error.aspx .

    Besides, the following article may also can give you some ideas:
    http://www.steveburgess.net/2013/02/unhelpful-error-messages-the-authentication-header-received-from-the-server-was-negotiatentlm/ .

    Best Regards,
    Amy Peng


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.


    Wednesday, November 5, 2014 10:30 AM
    Moderator