locked
Authentication stops working in classic ASP Pages RRS feed

  • Question

  • User411130030 posted

    I've been using the same code for years in order to authenticate to Active Directory through my classic ASP pages for years without any problems.  We just moved to a new Windows 2019 server and the code still works, however, very intermittently the server will stop responding and when a user attempts to log in, they will receive an error message stating that the username or password is incorrect even when the submitted information is correct.  I will then restart the server and it starts working again.  This happens three or four times a day and has only happened on this new server.  I never had this problem with our old web server.  We've checked logs and running services but cannot find any problems.  We've stopped and restarted IIS but that doesn't seem to fix the problem either.  Any help pointing me in the right direction would be great!

    Thursday, September 12, 2019 4:10 PM

All replies

  • User-848649084 posted

    Hi,

    Could you share which iis version before you are using, sample code, web.config setting and which authentication you set, under which identity your application pool is running? 

    make sure you disabled anonymous authentication.


    <!-- web.config -->
    <configuration> <system.web> <authentication mode="Windows" /> <authorization> <allow roles="MYDOMAIN\MY-AD-GROUP" /> <deny users="*" /> </authorization> </system.web> </configuration>
    <!-- applicationHost.config -->
    <configuration>
      <location path="YOUR-APP">
        <system.webServer>
          <security>
            <authentication>
              <anonymousAuthentication enabled="false" />
              <windowsAuthentication enabled="true" />
            </authentication>
          </security>
        </system.webServer>
      </location>
    </configuration>

    and check the folder permission that user have enough permission to access it. 

    Regards,

    Jalpa

    Friday, September 13, 2019 5:27 AM