locked
How to deploy to remote server RRS feed

  • Question

  • User-1793776479 posted

    Hi,

    I downloaded the timetracker starter kit and tried to run it in local host. In localhost it works fine but when I copy the website to my local server it gives me an error saying

     

    <title>Runtime Error</title><style> body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px} b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px} H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red } H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon } pre {font-family:"Lucida Console";font-size: .9em} .marker {font-weight: bold; color: black;text-decoration: none;} .version {color: gray;} .error {margin-bottom: 10px;} .expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; } </style>

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>
     

     

    Is there any other way to deploy it.

     

    Please Help!

    Thursday, February 12, 2009 1:07 PM

Answers

  • User-1793776479 posted

    I figured it myself.

    Thanks!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, February 18, 2009 9:47 AM

All replies

  • User595841651 posted

     

    do what it says and change the customErrors to see what the real error is.

    Odds are you have the wrong .Net version on the server....but without the error message (the real one) its tough to say.

    Thursday, February 12, 2009 1:11 PM
  • User-1793776479 posted

    I did try what it says. It still gives the same error. I think that there is someother way of doing this?

    Thanks!

    Thursday, February 12, 2009 1:33 PM
  • User595841651 posted

    look at the bottom of the error page... you will see the .Net version.....

    Is it what you expected?

    Thursday, February 12, 2009 1:50 PM
  • User-1793776479 posted

    No, It's not what I am expecting. I am sorry I guess you did not undertsand my question. I am trying to run the timtracket from my server which is something like 208.0.0.1/timetracker/login.aspx. When I am trying acces this page I am getting the above error. So I was wondering is there anyother different way to deploy the time tracker starter kit on the server. Like any specific setting etc etc.

     Thanks!

    Thursday, February 12, 2009 1:59 PM
  • User595841651 posted

    It's not the Deployment that's the issue....it's your server.

    Your server needs the right (or newer) version of .Net installed.... deploying the application wont upgrade the .Net version of the server....

     

    Thursday, February 12, 2009 2:08 PM
  • User-1793776479 posted

    <p>Hi,

    My server has .Net 2.0 installed on it. Also when I tried to copy it to the live srever, the login page is working but when I try to login or create a new user I get the above error?

     Thanks!

     </p>

    Thursday, February 12, 2009 2:23 PM
  • User595841651 posted

    and you set the customErrors="Off" in the web.config?

    How did you Deploy your site?

    Thursday, February 12, 2009 2:27 PM
  • User555306248 posted

    any updates on this

    Tuesday, February 17, 2009 10:23 PM
  • User-1793776479 posted

    I figured it myself.

    Thanks!

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, February 18, 2009 9:47 AM
  • User555306248 posted

    That nice, Please mark the answer that helps you so it will for other people

    Wednesday, February 18, 2009 10:22 PM
  • User555306248 posted

    Can you provide the solution, how you solved it

    Thursday, February 19, 2009 10:19 PM