locked
AppointmentManager.ShowAddAppointmentAsync works on Windows 8.1 Pro but not Windows 8.1 RT ? RRS feed

  • Question

  • Hi,

    In out application, we are using AppointmentManager.ShowAddAppointmentAsync to display the popup to add an item on the calendar.

    This works fine on Windows 8.1 Pro but does not work on Windows 8.1 RT (a popup saying "No apps are installed to complete this task (Windows.appointmentsprovider.addappointment...)")

    Is is a known bug ??

    Thanks,


    Thomas Lebrun [MVP] - Windows 8 / Windows Phone / WPF / SL: http://blog.thomaslebrun.net

    Tuesday, October 29, 2013 4:10 PM

Answers

  • Hi Thomas,

    I suspect you don't have the latest version of the Calendar app on your Windows RT system. We just confirmed that Calendar version 17.5.9600.20279 works as an appointment provider on Windows RT.

    --Rob

    Tuesday, October 29, 2013 11:36 PM
    Moderator

All replies

  • The error is pretty much what it says: you need to install an appointment provider app for the appointment manager to talk to. It sounds like you have one installed on your Windows 8.1 Pro system but not on your Windows 8.1 RT system.

    --Rob

    Tuesday, October 29, 2013 4:25 PM
    Moderator
  • Hi Rob,

    Thanks for your answer.

    Both of my machines are installed with the Calendar application and this one works fine on both machines.

    So I don't understand why I can see the popup on Windows 8.1 Pro and not RT (also, the popup which appears on Windows 8.1 Pro shows the Calendar data).

    Thanks,


    Thomas Lebrun [MVP] - Windows 8 / Windows Phone / WPF / SL: http://blog.thomaslebrun.net

    Tuesday, October 29, 2013 4:43 PM
  • Hi Thomas,

    I suspect you don't have the latest version of the Calendar app on your Windows RT system. We just confirmed that Calendar version 17.5.9600.20279 works as an appointment provider on Windows RT.

    --Rob

    Tuesday, October 29, 2013 11:36 PM
    Moderator
  • Hi Rob,

    Thanks for your reply.

    I've updated the apps on the W8.1 RT system and all works fine now, thanks again!

    Thanks,


    Thomas Lebrun [MVP] - Windows 8 / Windows Phone / WPF / SL: http://blog.thomaslebrun.net



    Wednesday, October 30, 2013 7:09 AM