locked
Reports not showing in the crystal report RRS feed

  • Question

  • User2031412921 posted

    Hai everyone,

    Im using crystal report for my invoice page... in that Datas are binding but the reports are not shown in the webpage

    can anyone pls help me to resolve this prblm...

    My code

    protected void Page_Load(object sender, EventArgs e)
        {
            OracleConnection conn = new OracleConnection(globalconnection.OracleConnectionString);
            string selectstring = "SELECT SENDERNAME,SENDERADDRESS,SENDERMOBILENO,SENDERPINCODE,RECEIVERNAME,RECEIVERPINCODE,RECEIVERADDRESS,RECEIVERMOBILE,COURIERWEIGHT,COURIERDIMWIDTH,COURIERDIMHEIGHT,COURIERDIMLENGTH,COURIERAMOUNT,TOTALAMOUNT FROM TOTAL_SHIPMENT_OVERALL";
            string Path = "invoicesample.rpt";
            string DataFill = "checkdata";
            conn.Open();
            OracleDataAdapter adp = new OracleDataAdapter(selectstring, conn);
            DataSet ds = new DataSet();
            adp.Fill(ds, DataFill);
            ds.Tables[0].TableName = "checkdata";
            adp.Fill(ds, DataFill);
            rptdoc.Load(Server.MapPath(Path));
            rptdoc.SetDataSource(ds);
            CrystalReportViewer1.ReportSource = rptdoc;
            conn.Close();
    
        }

    thanks in advance...

    Friday, May 6, 2016 8:18 AM

Answers

  • User2031412921 posted

    I found the mistake that i have done in my page....

    I missed to call the javascript here....

    javascript is here.....

    <script src="aspnet_client/system_web/4_6_79/crystalreportviewers13/js/crviewer/crv.js"></script>
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, May 6, 2016 11:07 AM

All replies

  • User527778624 posted

    Hi,

    adp.Fill(ds, DataFill); ds.Tables[0].TableName = "checkdata"; adp.Fill(ds, DataFill);

    From your code, i can see you are loading the table into dataset 2 times with same name.

    try removing last line.

    Friday, May 6, 2016 8:28 AM
  • User2031412921 posted

    I found the mistake that i have done in my page....

    I missed to call the javascript here....

    javascript is here.....

    <script src="aspnet_client/system_web/4_6_79/crystalreportviewers13/js/crviewer/crv.js"></script>
    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, May 6, 2016 11:07 AM