none
VSTO ClickOnce setup.exe gives hourglass cursor for 4-5 minutes and does nothing RRS feed

  • Question

  • I have written an Excel VSTO add with Visual Studio 2010.

    I publish the app via Build, Publish to a local folder on my dev machine and then copy the folder to the server.

    From the client system, I map the server folder using WebDav to a drive (P:)

    Then from the client, run the setup.exe

    The setup works on 3 different computers in that it installs the Excel AddIn and everything works fine.

    On a fourth computer (Windows 7 Home Premium), when I run setup.exe, I get an hourglass for 4-5 minutes and then the hourglass goes away. The AddIn is never installed and I never get an error message. So where do I go to debug this?

    I have already tried setting the LogFilePath in the registry and I do not get a log file. I have checked Event Viewer and there are no unusual events there either.

    If anyone has some ideas on things to try, I would appreciate it.

    Billy C.

    Tuesday, May 3, 2011 10:30 PM

Answers

  • First I would try to use the VSTO Power Tools and check on the client if there is a missing prerequisite.

    Office Pro

    .Net Framework

    Then - if all prerequisites are on the machine - we go further...

    Greets - Helmut


    Helmut Obertanner [http://www.x4u.de] [http://www.outlooksharp.de]
    • Marked as answer by Bruce Song Thursday, May 12, 2011 2:32 AM
    Wednesday, May 4, 2011 6:51 AM
    Answerer

All replies

  • First I would try to use the VSTO Power Tools and check on the client if there is a missing prerequisite.

    Office Pro

    .Net Framework

    Then - if all prerequisites are on the machine - we go further...

    Greets - Helmut


    Helmut Obertanner [http://www.x4u.de] [http://www.outlooksharp.de]
    • Marked as answer by Bruce Song Thursday, May 12, 2011 2:32 AM
    Wednesday, May 4, 2011 6:51 AM
    Answerer
  • Hi Billy,

    Have you resolved your problem yet, and do the suggestions help you? If you still have any concern on the thread, feel free to follow up.

    Best Regards,




    Bruce Song [MSFT]
    MSDN Community Support | Feedback to us
    Get or Request Code Sample from Microsoft
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, May 10, 2011 7:56 AM