none
WCF-SQL adapter installation RRS feed

  • Question

  • Hi,

    I installed WCF-SQL adapter and can't see the binding or the new adapter in BTS Admin console.  My OS is Windows 2008, .NET 4.0 framework.  The actual installations were WCF-LOB Adapter Pack, v2.0SP2 and BizTalk Adapter pack v3.0, all complete installs.  I modified machine.config in both .NET\v4.0... and .NET\v2.0.. directories.  What am I missing?

    Thanks a lot,

    Alex

    Friday, May 24, 2013 10:29 PM

All replies

  • BizTalk Adapter pack v2.0, I could not find a later version.  I am using Visual Studio 2010, will the Adapter pack still work, because I cannot see "Consume Adapter Service" or any of the bindings or adapters.

    Friday, May 24, 2013 10:45 PM
  • First of all, don't use the Adapter Pack 2.0 together with BizTalk Server 2010. The Adapter Pack 2010 (and the SDK) is located on the BizTalk 2010 media, found in the folders:

    -AdapterPack_x86 *

    -AdapterPack_x64 *

    -ASDK_x64 *

    ASDK_x86.

    I assume that you are running on some 64bit OS, and you therefore need to install all the artifacts with an (*) (the 32 bit version of the Adapter Pack is required for Visual Studio and the BizTalk Administration Console).

    Morten la Cour


    • Edited by la Cour Monday, May 27, 2013 11:43 AM
    Monday, May 27, 2013 11:43 AM
  • You have to install both the 32 and 64 bit versions of the WCF Adapters.  Along with the appropriate version of the SDK.  The Installation Guide has all the details.
    Monday, May 27, 2013 7:11 PM
  • And another piece, I can't remember its name.  In 2010, you install everything from the main BizTalk setup, and, for the adapters, it has all four components you need to install.  Thanks.
    Wednesday, May 29, 2013 7:34 PM
  • Take a look at this thread for further guidance http://social.msdn.microsoft.com/Forums/en-US/biztalkr2adapters/thread/0c6bf1b1-ce23-49a1-92d4-39c42b4a0c47

    Colin Meade (MCTS BizTalk Server) http://midheach.wordpress.com

    Saturday, June 8, 2013 12:19 AM