Error 1935 (HRESULT: 0x8007054F) trying to install software RRS feed

  • General discussion

  • As of Sept. 24th 2012 - this problem still persists. I have seen on the internet discussions, related to -

    01. Windows Installer not updated to the latest
    02. While Installing - Transaction Log got corrupted
    03. Dot net framework not updated

    Since 01 and 03 were not our case, we followed the solution related to 02.

    Observation is - for a machine where the product was not installed with earlier version - this method of solution works fine.

    Question remains - Why should the "Installation Transaction Log" get corrupted ??

    And, on another machine, where there was an earlier version installed, even after uninstalling and removing all traces of the product of earlier version - did not allow to install and gives the same error message.

    Why the earlier version of the same product does not have this issue ?

    Why the new version ( we are the producer of the product) corrupts the transaction Log ? - We are using the same machine for creating setups with Install Shield 2009.

    Any advice will be highly appreciated.


    Dated - Oct 01, 2012 - Somehow ( I can not explain how) I thought that the Product packaging is responsible for it and one idea / reason came to my mind - there must be some component / dll in the product - which is not signed and hence Windows 7 and Windows 8 registry update is not allowed.

    So, I re-created the setup after signing all dlls - yes, there were some dll which were not digitally signed.

    The problem vanished.

    Hope this helps others.

    Wednesday, October 3, 2012 4:28 AM

All replies

  • Hi SSG:

    Thanks for sharing your experience there, It’s very beneficial for other community members who have similar problem to see how you solved it.

    Have a good day,


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, October 4, 2012 2:13 AM