none
Receiving error 'The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine' RRS feed

  • Question

  • I am debugging an .NET 4.0 application that has been in production for several years. The application was built on the same workstation as I am getting this error, I have debugged the application countless times before (though it has been a few months since the last time), and I have never received this error in the past.

    This application writes info to an Excel spreadsheet using ADO.NET, and when the code generates the spreadsheet is when the error occurs.

    The only thing that has changed on my system is last week Office 2010 SP2 was installed via update. Would this have changed my drivers?


    Edit: The only solutions I see anywhere are for people who are getting this error for the first time, and all of them seem to point to the Microsoft downloads. I did try downloading the drivers and installing them again, but I am still getting this error.
    Monday, November 4, 2013 5:38 PM

Answers

All replies

  • Hi J,Hermes,

    Thank you for posting in the MSDN Forum.

    Since your issue is more relate to ADO.NET Managed Providers, I'd like to move it to ADO.NET Managed Providers forum for better support.

    Thank you for your understanding.

    Best regards

    Fei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, November 5, 2013 7:20 AM
  • If you are running in a 64-bit Windows environment you need to make certain that the Platform (Build...Configuration Manager) supports the version of the database library you are using. For example, if the Platform option is set to Any CPU or x64 the app will run 64-bit. The would require that the 64-bit version of ACE be installed. If instead, 32-bit ACE is installed (or 32-bit Microsoft Office), then the Platform option will need to be changed to x86 so that the app will run 32-bit on a 64-bit system.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Tuesday, November 5, 2013 2:24 PM
  • That would be fine, thanks (my apologies, I wasn't exactly sure where my question should go).
    Tuesday, November 5, 2013 9:29 PM
  • This was it, I can't believe I overlooked it! Thanks.
    • Marked as answer by J. Allred Tuesday, November 5, 2013 9:29 PM
    Tuesday, November 5, 2013 9:29 PM