locked
Setup SSO using ADFS3.0 & DIRSYNC RRS feed

  • Question

  • We are deploying ADFS for Office365 for SSO with DIRSYNC on Windows 2012 R2.

    Appreciate if someone can point us in the correct direction to configure this? Maybe a step by step guide.

    We need the on premise users to logon to office365 using the SSO.

    Appreciate your help.
    Wednesday, August 5, 2015 2:22 AM

Answers

All replies

  • We are deploying ADFS for Office365 for SSO with DIRSYNC on Windows 2012 R2.
    We need the on premise users to logon to office365 using the SSO.

    Greetings!

    Here's a flow of how you can start and proceed with configuration of SSO with Office 365, deploying ADFS and directory synchronization:

    1/ Prepare your Active Directory Domain

    2/ Prepare your server and Install ADFS

    3/ Add your UPN domain to Office 365

    4/ Connect ADFS with Office 365

    5/ Synchronize Active Directory user account information to Office 365

    6/ Assign Office 365 licenses to users

    7/ Verify Federation and Synchronization

    Reference: https://support.office.com/en-ca/article/Office-365-integration-with-on-premises-environments-263faf8d-aa21-428b-aed3-2021837a4b65 (Discusses Office 365 integration with various scenarios)

    Step-by-Step Reference: http://blogs.technet.com/b/canitpro/archive/2013/06/13/step-by-step-setting-up-ad-fs-and-enabling-single-sign-on-to-office-365.aspx

    Hope this helps!

     

    Thank you,

    Arvind 

    Wednesday, August 5, 2015 7:27 AM
  • We are having a major issue setting up SSO using Dirsync with ADFS & also with Azure Connect.

    We have the ADFS setup on Windows 2008 R2 Server and DIRSYNC on another Windows 2008 R2 server.All was working well for over a year and for some reason we had a hardware failure and DIRSYNC server was tossed.

    Now we are trying to activate this DIRSYNC serverand we have tried installing this on a fresh WIndows 2008 R2 and Windows 2012 R2 servers and failed. 

    The installation fails during the installation of the Synchronisation Service. We get a message saying an error occured during installation and to check logs. On checking logs all we see is

    "Microsoft.Azure.ActiveDirectory.Synchronization.Framework.ProcessExecutionFailedException: Exception: Execution failed with errorCode: 1603."

    We tried using the dirync.exe \fullsql and the installtion completes but when we try to run

    PS C:\program files\Windows Azure Active Directory Sync> .\DirSyncInstallShell.psc1
    .\DirSyncInstallShell.psc1 : The term '.\DirSyncInstallShell.psc1' is not recognized as the name of a cmdlet,
    function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the
    path is correct and try again.

    We cannot find DirSyncInstallShell.psc1 in the path.

    We also tried installing using the below tools and still run into an error exactly during the stage of "installing synchronisation service"

    1. AzureADConnect
    2. MicrosoftAzureADConnectionTool

    Kindly advise to us on the best way to sort this out to enable SSO.
    Thursday, September 3, 2015 6:44 AM