none
ReportViewer Error - An error has occurred during report processing. Cannot open database "SumaCard_SQL" requested by the login. The login failed. Login failed for user 'NT AUTHORITY\NETWORK SERVICE'. RRS feed

  • Question

  • I have created a web site on the server which has 3 reports on it.  The reports all show fine in development but after I have published them (same machine public fiolders) I get the following error.

    An error has occurred during report processing. Cannot open database "SumaCard_SQL" requested by the login. The login failed. Login failed for user 'NT AUTHORITY\NETWORK SERVICE'.

    I had the Server Admins check to make sure that SQL and IIS have the NT Authority/Network Services in the Login security and they are.

    Can any tell me what I am missing?

    Thanks


    SquireDude
    Monday, December 20, 2010 5:41 AM

Answers

  • Fixed it...

    I changed the access from the NT Authority to SQL and this error disapeared.


    SquireDude
    • Marked as answer by SquireDude Monday, December 20, 2010 6:26 AM
    Monday, December 20, 2010 6:26 AM

All replies

  • Fixed it...

    I changed the access from the NT Authority to SQL and this error disapeared.


    SquireDude
    • Marked as answer by SquireDude Monday, December 20, 2010 6:26 AM
    Monday, December 20, 2010 6:26 AM
  • hey, I get the same error from my web app using the Report Viewer. How did you solve your error exactly?

     

    thank you!!


    Developer
    Friday, November 18, 2011 7:28 PM
  • Hi Alex33USA,

    I went back into SQL and changed the login process from NT Authentication or mixed to SQL... added a user and password and it resolved the issue for me. 

    Hope this helps resolve your issue too?

    Phill


    SquireDude
    Friday, November 18, 2011 7:58 PM