none
Visual Studio 2013 Installation Problem

    Question

  • I am developing in VS 2013 with Installshield Limited Edition under Windows 10. The development and the installations have been working fine up till now, but now while the installer does install the application on other PCs (Win 8.1), when I click on the installed application to run it there is a message saying "This App does not run on your PB. Contact the publisher for a suitable version." 

    There was a compiler warning (not error) about including the .NET framework when I compile the install module. However I have included all the versions of Instalshield on the limited edition installation wizard and the message still comes up when I try to run the app.

    What do I need to do?

    Thank you

    Thursday, December 15, 2016 2:28 AM

All replies

  • Hi Clinton,

    Welcome to the MSDN forum.

    Refer to the error message “This App does not run on your PC. Contact the publisher for a suitable version”, it looks like there has the compatibility issue or the installer maybe corrupted.

    Please have a look at the following to troubleshot this issue:

    1. Please see this: .NET Framework Deployment Guide for Developers and we can find the information about setting a dependency on the .NET Framework for InstallShield Deployment, go to Installation Requirements and select the operating systems and the version of the .NET Framework you want to install. You can check this setting of your customer installer and make sure it configures the windows 8.1 and the .NET Framework Versions that already installed on windows 8.1.

    2. Check the file size of the installer that you copy to the other PCs, some other meet this similar error message due to the size is Zero.

    3. Make a copy of .exe file you’re trying to run, you can try to use Ctrl+C and Ctrl+V to create a new .exe file and run it again.

    4. Temporarily disable any antivirus software and re-run the installer as administrator.

    >> There was a compiler warning (not error) about including the .NET framework when I compile the install module.

    Did you meet this issue on your windows 10 or windows 8.1 computer? Could you please provide the detail warning message or share the screenshot of this screen, thank you for your support.

    Best regards,

    Sara


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 16, 2016 6:43 AM
    Moderator