none
.Net 3.5 will not install (Win XP SP2) RRS feed

  • Question

  • Hello - I have been trying now for a few hours to get .Net 3.5 installed on my machine, and it absolutely refuses to install.  My ultimate goal is to get VS Express C# installed, but I can't get past this step.

     

    Here is a list of things I have done, and the results I've gotten:

     

    - Tried web install.  It errors out and says it cannot download the files.

     

    - Downloaded full package dotnetfx35.exe (197 MB) 3 times.  When I run it, it gets to about 80% extraction and errors out with "Extraction Failed - File is corrupt."  I cannot see the full file name that this error occurs on because the window is too small, but here's what I can see:  "Extracting File:  wcu\.\.\.\.\.\dotNetFramework\dotNetMSP\x6"

     

    - Downloaded VS2008ExpressENUX1397868.iso (DVD ISO with all VS Express versions) and attempted to let the C# installer handle .Net 3.5 installation.  It errors out at the .Net 3.5 install step and will not proceed.

     

    - Tried VS Express C# web installation - same results after download:  errors out at the .Net 3.5 install step.

     

    - Downloaded and used the clean-up tool and followed the steps listed on Aaron Stebner's blog located here:  http://blogs.msdn.com/astebner/archive/2005/10/11/479928.aspx

     

    - Repeated all of the above after multiple complete uninstall -> reinstalls of all versions of .Net Framework up to 3.0.

     

     

    I'm stumped.  I don't know what else to do. Sad

     

    I am on Windows XP SP2 and I have VS 2005 installed.  Prior to these attempts, I had VS 2008 beta 2 installed (which I believe had the .Net 3.5 framework beta installed with it).  I uninstalled it before attempting to install the VS Express C# release.

     

    Any help would be greatly appreciated, as I'm quite frustrated at this point.

     

    Thanks!

     

    Michael

    Wednesday, November 28, 2007 11:35 PM

All replies

  •  

    Hi Michael,

     

    Sorry that you're having trouble with your installation!  Here's a couple of things to try.

     

    1. Have you specifically uninstalled the .Net Framework 3.5 that was installed with VS 2008 Beta 2?  I believe it isn't uninstalled by uninstalling Visual Studio, and it could prevent installation of the final version of the framework.

     

    2. If that doesn't solve your problem, you could send us the logs so that we can see the problem specifically.  The easiest is to use the log collection tool from Aaron Stebner's weblog http://blogs.msdn.com/astebner/archive/2007/11/21/6458047.aspx and then send the resulting vslogs.cab file to me via email (ndoty at microsoft dot com).

     

    Hope this helps,

    Nick Doty - MSFT

    Thursday, November 29, 2007 2:09 AM
  • Thanks Nick, I have done both.  Looking forward to your response.  I hope you can make heads or tails out of the logs! Smile

     

    Thursday, November 29, 2007 10:32 PM
  •  

    Here's the relevant section of Michael's dd_dotnetfx35error.txt file:

     

    Code Block
    [11/29/07,10:43:39] Microsoft .NET Framework 2.0a: [2] Failed to fetch setup file in CBaseComponent::PreInstall()
    [11/29/07,10:43:39] setup.exe: [2] ISetupComponent::Pre/Post/Install() failed in ISetupManager::InternalInstallManager() with HRESULT -2147467260.
    [11/29/07,10:43:39] setup.exe: [2] CSetupManager::RunInstallPhase() - Call to Pre/Install/Post for InstallComponents failed
    [11/29/07,10:43:39] setup.exe: [2] CSetupManager::RunInstallPhaseAndCheckResults() - RunInstallPhase() returned a NULL piActionResults
    [11/29/07,10:43:39] setup.exe: [2] CSetupManager::RunInstallFromList() - RunInstallPhaseAndCheckResults failed [2]
    [11/29/07,10:43:39] setup.exe: [2] ISetupManager::RunInstallLists(IP_PREINSTALL failed in ISetupManager::RunInstallFromThread()
    [11/29/07,10:43:39] setup.exe: [2] ISetupManager::RunInstallFromThread() failed in ISetupManager::RunInstall()
    [11/29/07,10:43:39] setup.exe: [2] CSetupManager::Run() - Call to RunInstall() failed

     

     

    It looks like there's at least one other thread on MSDN concerning the same issue: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2090947&SiteID=1

    That customer was apparently able to resolve the problem just by restarting their machine and re-attempting the install, but it appears that you've tried that already.  Also, we commonly see errors like this when there's a problem completing the .Net 3.5 download or extracting the files, but I would expect downloading the complete package or a DVD ISO would resolve that problem.  I'll try to contact others here at Microsoft who might know more about this issue. 

     

    Can you tell me which type of installation failed in this log (the morning of November 29th) -- if this log is the result of an incomplete or corrupt download that might throw us off the track.  Perhaps you could send the logs from running the install from the ISO (assuming that isn't giving you the same error message about failure to extract.

     

    Thanks,

    Nick Doty - MSFT

    Tuesday, December 4, 2007 10:01 PM