locked
One or more parameters were not specified for the subreport RRS feed

  • Question

  • I am using SSRS 2008 R2 and keep getting the above error in BIDS.  How do I troubleshoot this error?  This error message is not detailed enough!  This subreport works by itself.  But something is not working when I run the parent report. 

    Ryan D

    Tuesday, September 25, 2012 4:53 PM

Answers

  • Thanks, I found the problem.  The problem was that the parent RDL used the same sproc as the child report and since the parent report included more parameters the error was actually referring to the parent report.

    Ryan D

    • Marked as answer by ironryan77 Tuesday, September 25, 2012 6:37 PM
    Tuesday, September 25, 2012 6:36 PM

All replies

  • If you open the subreport directly, does it generate the report with no user input? If so then look at the default values of the parameters in the subreport. Check for any that are based on expressions and be sure that they produce a valid value when run from within the main report. If not, the values you provide when running the report locally must be supplied from the main report.
    Tuesday, September 25, 2012 5:36 PM
  • Thanks, I found the problem.  The problem was that the parent RDL used the same sproc as the child report and since the parent report included more parameters the error was actually referring to the parent report.

    Ryan D

    • Marked as answer by ironryan77 Tuesday, September 25, 2012 6:37 PM
    Tuesday, September 25, 2012 6:36 PM