locked
FAQ Item: Erroneous “Framework [x].[x].[x] is not installed” message when the Framework is present RRS feed

  • Question

  • I've updated my add-in to use a newer version of the .NET Framework, included it in the pre-requisites for installation and published it. My clients are getting an error message that the .NET Framework is not installed, so the solution cannot be loaded:

    What's wrong?


    Cindy Meister, VSTO/Word MVP, my blog

    Sunday, October 27, 2013 6:21 AM
    Moderator

All replies

  • Even though the version of the .NET Framework may be installed on the client machine, it's possible that the corresponding version of the VSTO Runtime has not yet been installed. This could be causing the error message.

    The newest version of the VSTO runtime can be found at:

    http://go.microsoft.com/fwlink/?LinkId=140384

    It's important to realize that Office only installs the version of the VSTO Runtime that was current at the time the Office version was released. In order to run VSTO solutions compiled with a more recent version of the Tools a newer version of the Runtime may be required. On first installation of a solution, this can be checked and installed using a Bootstrapper package. For updates it may be necessary to have the client downlaod and install a newer version of the Runtime.


    Cindy Meister, VSTO/Word MVP, my blog

    Sunday, October 27, 2013 6:27 AM
    Moderator