locked
HTTP Error 403.14 - Forbidden RRS feed

  • Question

  • User-1418567014 posted

    I got the error in a simple ASP.NET WEB API 2 project.

    HTTP Error 403.14 - Forbidden

    The Web server is configured to not list the contents of this directory.

    So I configured IIS Express in Windows 7.

    I am sure that I enabled the Directory Browsing. See the image.

    https://www.flickr.com/photos/67801243@N06/24637214291/in/dateposted-public/

    But nothing changed.

    Sunday, January 31, 2016 3:32 PM

Answers

  • User-1418567014 posted

    Find the cause. The IIS Express doesn't work in a stable state. Not sure why, but I will make another try in a different laptop.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, February 2, 2016 3:14 AM

All replies

  • User-166373564 posted

    Hi,

    HTTP Error 403.14 - Forbidden

    The Web server is configured to not list the contents of this directory.

    If you are an end-user, you should contact the website administrators in order to let them know that this error has occurred for this URL address. Then, the website administrators will fix this issue later.

    To resolve this problem, follow these steps:

    1. Start IIS Manager. To do this, click Start, click Run, type inetmgr.exe, and then click OK.
    2. In IIS Manager, expand <var class="sbody-var">server name</var>, expand Web sites, and then click the website that you want to modify.
    3. In the Features view, double-click Directory Browsing.
    4. In the Actions pane, click Enable.

    Method 2: Add a default document

    To resolve this problem, follow these steps:

    1. Start IIS Manager. To do this, click Start, click Run, type inetmgr.exe, and then click OK.
    2. In IIS Manager, expand <var class="sbody-var">server name</var>, expand Web sites, and then click the website that you want to modify.
    3. In the Features view, double-click Default Document.
    4. In the Actions pane, click Enable.
    5. In the File Name box, type the name of the default document, and then click OK.

    Regards,

    Angie

    Monday, February 1, 2016 7:08 AM
  • User-1418567014 posted

    Oops, I just found in IIS, the content under Sites\Default Web Site is empty. It is a local desktop web application. Why?

    Monday, February 1, 2016 1:29 PM
  • User753101303 posted

    Hi,

    How are you supposed to install this application? Sites\Default Web Site seems to just be the default IIS site which might be empty and even disabled sometimes if it is not used.

    More likeky it seems you shoud have some installation step if you really have to run this web site on a local machine (which looks weird for a web app). Or t is not installed in Sites\Default Web Site

    Is this your own or a 3rd party app? Don't your run this application for VS?

    Monday, February 1, 2016 2:02 PM
  • User-1418567014 posted

    I don't install it. It is a simple asp.net web api 2 project in VS 2015. Which is similar with http://www.asp.net/web-api/overview/getting-started-with-aspnet-web-api/tutorial-your-first-web-api.

    Should I install it? The tutorial on the link doesn't mention it. By the way, I use IIS Express.

    Monday, February 1, 2016 2:30 PM
  • User753101303 posted

    Then no but then Sites\Default Web Site is not the web site folder?

    Ah, could it be that you created an empty web project without any default page? What if you try to add a default web page or controller you could use as a test to call your web api?

    I'm trying to understand what is the situation on your side as usually it just works. My understanding would be that you just have no default page so IIS doesn't have any thing to show and tries to show the folder content (which is usually disabled and should stay that way).

    What if you add a default.aspx page or a default controller? If for nothing help this page could be used to test your web api.

    Monday, February 1, 2016 6:15 PM
  • User-1418567014 posted

    I am not sure that I understand your question. But I think that I have to create the virtual directory. And I did it, and VS showed it was created. However I can not find it either in c:\interpub\wwwroot or IIS manager root Sites\Default Web Site.

    Tuesday, February 2, 2016 1:40 AM
  • User-782232518 posted

    IIS Express is not IIS, so that you cannot check C:\inetpub\wwwroot nor use IIS Manager.

    I do have a tool called Jexus Manager which can help you manage IIS Express,

    https://jexus.codeplex.com/releases/view/138373 

    You can add your project's IIS Express configuration as a new server and then manage it,

    https://blog.lextudio.com/2015/10/jexus-manager-renamed-and-local-iis-express-custom-configuration-support/ 

    Tuesday, February 2, 2016 2:15 AM
  • User-1418567014 posted

    Find the cause. The IIS Express doesn't work in a stable state. Not sure why, but I will make another try in a different laptop.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, February 2, 2016 3:14 AM