locked
Unable to start SQL Server Reporting Services. RRS feed

  • Question

  • When I try to start Reporting services for SQL Server 2008 R2 its failing with error message.

    " The SQL Server Reporting Services (MSSQLSERVER) service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs. "


    Checked with the application log which is coming up with below message.


    Service cannot be started. System.Exception: Default appdomain failed to initialize.

    at Microsoft.ReportingServices.Library.ServiceAppDomainController.Start()

    at Microsoft.ReportingServices.Library.ReportService.OnStart(String[] args)

    at System.ServiceProcess.ServiceBase.ServiceQueuedMainCallback(Object state)


    Can any one please help me resolve the issue.

    Thank,
    Praveen


    Praveen

    Tuesday, September 3, 2013 9:35 AM

Answers

  • Thank you for the reply, I figued the problem now, somebody deleted rsreportserver.config at C:\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer.  restoring the config file from backup resolved the issue.


    Praveen

    • Marked as answer by Mike Yin Thursday, September 5, 2013 3:37 PM
    Tuesday, September 3, 2013 1:42 PM

All replies

  • hii praveen 

    check ..

    goto 

    start->All Program->Sql server 20??->Configuration Tools->Sql server Configuration manager

    check sql server services.. is ssrs service running? if not start it by right clicking


    Dilip Patil..

    Tuesday, September 3, 2013 12:59 PM
  • Launch the SQL Server Configuration Manager using "Run as administrator" and then retry.

    Take a look on  link http://www.sqlservercentral.com/Forums/Topic186166-146-1.aspx it may helps you

    Tuesday, September 3, 2013 1:33 PM
  • Thank you for the reply, I figued the problem now, somebody deleted rsreportserver.config at C:\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer.  restoring the config file from backup resolved the issue.


    Praveen

    • Marked as answer by Mike Yin Thursday, September 5, 2013 3:37 PM
    Tuesday, September 3, 2013 1:42 PM