none
Sharepoint 2013 extranet exteremly slow compared to intranet RRS feed

  • Question

  • Hello,

    i am having issues getting my extranet working in normal speeds. Comparted to my intranet its exteremly slow, for example opening calendar takes 5-7 seconds for it to fill out with events. when in intranet it happens instantly.

    The only differance is that extranet is running over my HAproxy server, can it be that i have set up HAproxy false or perhaps HAproxy is just not what i should use ( i am planning to replace it with a proper proxy server in the future).

    Would just like to know if someone has any feedback regarding this issue.

    Friday, January 27, 2017 12:04 PM

All replies

  • Hi,

    Please check the memory and pipe (inadequate bandwidth or network issues).

    Or please try to create a simple ASP.NET project and deploy it to your extranet server, then check whether the page still open extremely slow or not.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, January 30, 2017 7:00 AM
    Moderator
  • Hi,

    Actualy it seems that the page opening is same speeds as intranet, but opening data that is connected to the database is taking forever. for example opening documents and list item metadata is the thing that is slowed down.

    Tuesday, January 31, 2017 3:00 PM
  • Hi,

    Please check the network between your extranet server and SQL server.

    Best Regards,

    Dennis


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Wednesday, February 1, 2017 8:32 AM
    Moderator
  • Hi,

    There might be problem with network from where you are accessing SP Site, this could be firewall problem, some rules at netword side or some proxy settings etc.

    Try to access the same URL from some another network (use data card). I hope you will see the difference.

    If still not work, use fiddler trace to figure out problem.


    Vivek Jagga
    My Blog
    Follow Linkedin Group   


    Wednesday, February 1, 2017 9:13 AM