none
Deployment Issue for Outlook 2010 Add-in Project RRS feed

  • Question

  • Hi,

    I have a Created a Outlook 2010 Add-in project and deployed using the setup project which created using the visual studio.

    This Setup working fine in development machine and I can see all my customization in Outlook

    But, when comes to production server the Add-in is loaded into Outlook but all my Customization i.e custom button in a ribbon and Context menu Item for a Mail Item is not visible.

    Both the Machines I am Using 64-bit OS and 32-bit Office 2010.

    Can anyone please tell me the chances of doing wrong.


    Thanks, Swaroop Vuppala

    Wednesday, August 8, 2012 9:56 AM

Answers

  • then most probably there is something wrong in your getcustomui function that crashes and therefore outlook does not show your ribbon customizations. Add some try catch and logging there.
    Monday, August 13, 2012 11:40 AM

All replies

  • Hello,

    I had a similar problem with a FormRegion Addin project. Do you have checked the registry settings? Do you have already compared the registry setting from both machines? Maybe this article helps?

    Regards

    Wednesday, August 8, 2012 11:08 AM
  • are you sure that your add-in is actually loaded on production? and nitpicking a little - production server? add-in is installed on every client computer, not o a server - unless you are taling about citrix or remotde desktop server?
    Wednesday, August 8, 2012 11:13 AM
  • Hi Damian,

    Thanks for your response.

    I have installed the Add-in in a Server through Cittrix.

    I am very sure that my add-in was loaded successfully, because of these reason:

    I have added a Custom button in a ribbon and a Edit Box in a backstage view through Ribbon.xml

    And i have also added a Context menu Item programatically at a runtime through a ThisAddin.cs

    I can see this Context menu which added through code but all items which added through ribbon.xml is not visible.

    But this is working fine in my local environment.


    Thanks, Swaroop Vuppala

    Monday, August 13, 2012 5:48 AM
  • Damian,

    I have observed that there was a other custom tab which already installed in a server in which i am going to install my Add-in.

    Is this causing an issue to my Ribbon.xml ?

    Please help me in this.


    Thanks, Swaroop Vuppala

    Monday, August 13, 2012 5:52 AM
  • other custom tab (added by other add-in) that you want to add your buttons to? it will only work if you are both using exactly the same namespaces (xml namespaces) in your ribbon.xml files.

    Or do you mean that there is already other ribbon customization? if that is the case you should have no clashes.

    Try something like this:

    outlook menu File -> options -> advanced -> Developers -> show addin user interface errors

    check it on, and restart your add-in or whole outlook and see if there are any messageboxes with error info.

    Monday, August 13, 2012 7:20 AM
  • Damian,

    I had tried this but I didn't get any error info.

    Any other troubleshooting ways would help me ?


    Thanks, Swaroop Vuppala

    Monday, August 13, 2012 9:08 AM
  • right click ribbon, choose customize ribbon and in popped up window try to find your custom tab. maybe some other add-in or completly different thing imports predefined ribbon customization from file and that is why your tabs are invisible. Try to dinf your tab and either check it or add it to ribbon.
    Monday, August 13, 2012 9:29 AM
  • Damian,

    But it was not avilable in this list also to add it.

    So what might be the issue ?


    Thanks, Swaroop Vuppala

    Monday, August 13, 2012 9:56 AM
  • how do you add your context menu customization? also by xml or by handling event handler?

    Monday, August 13, 2012 11:13 AM
  • I have added context menu by event handler

    Thanks, Swaroop Vuppala

    Monday, August 13, 2012 11:17 AM
  • then most probably there is something wrong in your getcustomui function that crashes and therefore outlook does not show your ribbon customizations. Add some try catch and logging there.
    Monday, August 13, 2012 11:40 AM